[SOLVED] inference_engine library for yocto release

[SOLVED] inference_engine library for yocto release

It seems the yocto release are missing library for poky. After installing intel_cv_sdk_yocto_r2_2017.0.113.tgz on camera. I tried to compile the inference_engine samples. But there is no poky library for inference engine, instead it only has ubuntu_14.04.

 

$ cd /media/card/opt/intel/computer_vision_sdk_2017.0.113/inference_engine/samples/build

$ cmake -DCMAKE_BUILD_TYPE=Release ..

-- /etc/*-release distrib: poky 2.0

poky 2.0 is not supported. List of supported OS: Ubuntu 14.04, Ubuntu 16.04, CentOS 7

$ find /media/card/opt/intel/computer_vision_sdk_2017.0.113/inference_engine/lib

/media/card/opt/intel/computer_vision_sdk_2017.0.113/inference_engine/lib

/media/card/opt/intel/computer_vision_sdk_2017.0.113/inference_engine/lib/ubuntu_14.04

/media/card/opt/intel/computer_vision_sdk_2017.0.113/inference_engine/lib/ubuntu_14.04/intel64

/media/card/opt/intel/computer_vision_sdk_2017.0.113/inference_engine/lib/ubuntu_14.04/intel64/libclDNNPlugin.so

/media/card/opt/intel/computer_vision_sdk_2017.0.113/inference_engine/lib/ubuntu_14.04/intel64/libinference_engine.so

/media/card/opt/intel/computer_vision_sdk_2017.0.113/inference_engine/lib/ubuntu_14.04/intel64/libMKLDNNPlugin.so

 

Best regards,

Dong

2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

The work around is to link with ubuntu_16.04 library that copied from the release for ubuntu.

Leave a Comment

Please sign in to add a comment. Not a member? Join today