Human pose estimation

Human pose estimation

Hi,

I am able to run human pose estimation demo with CPU and NCS1, but NCS is stack at parsing input parameters, any advice ?

 

Thanks, 

Vurc.

13 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Dear Vurc,

did you mean  NCS is stuck  (not stack) at parsing input parameters, any advice ? I'm not sure what you mean by this. Can you kindly be more specific about the problem ?

Thanks,

Shubha

Hi,

when I start human pose estimation demo, console is stuck at following message : Parsing input arguments. 

InferenceEngine:
        API version ............ 1.6
        Build .................. 23780
[ INFO ] Parsing input parameters

This only happens with NCS2.

Thanks,

Vurc

Hi,

is there any update on this?

Thanks,

Vurc.

Dear Vurc,

I tried the latest OpenVino 2019 R1.1 release and unfortunately you're correct, it seems to be broken. You are correct, it gets stuck as follows:

C:\Users\sdramani\Documents\Intel\OpenVINO\inference_engine_samples_build\intel64\Release>human_pose_estimation_demo.exe -i cam -m c:\users\sdramani\Downloads\human-pose-estimation-0001.xml -d MYRIAD
InferenceEngine:
        API version ............ 1.6
        Build .................. 23780
[ INFO ] Parsing input parameters

I can assure you that it's fixed in the next release however. I know this because I've tested it. I'm terribly sorry that you've experienced this inconvenience !

Please wait for the next release and it will be fixed.

Sincerely,

Shubha

 

I also tested it with both NCS 1 and NCS 2. Just for your reference.

For NCS 1, there was error message but followed by normal execution:

InferenceEngine: 
	API version ............ 1.6
	Build .................. custom_releases/2019/R1.1_28dfbfdd28954c4dfd2f94403dd8dfc1f411038b
[ INFO ] Parsing input parameters
E: [ncAPI] [    332117] ncDeviceOpen:672	Failed to find suitable device, rc: X_LINK_DEVICE_NOT_FOUND
To close the application, press 'CTRL+C' or any key with focus on the output window
[ INFO ] Execution successful

 

For NCS 2, there's only errors without any output:

InferenceEngine: 
	API version ............ 1.6
	Build .................. custom_releases/2019/R1.1_28dfbfdd28954c4dfd2f94403dd8dfc1f411038b
[ INFO ] Parsing input parameters
E: [ncAPI] [    373198] ncDeviceOpen:672	Failed to find suitable device, rc: X_LINK_DEVICE_NOT_FOUND
E: [xLink] [    597121] dispatcherEventReceive:347	dispatcherEventReceive() Read failed -1 | event 0x7fe2a9b28c60 XLINK_READ_REL_REQ

E: [xLink] [    597121] eventReader:233	eventReader stopped
E: [watchdog] [    597712] sendPingMessage:132	Failed send ping message: X_LINK_ERROR
E: [watchdog] [    598711] sendPingMessage:132	Failed send ping message: X_LINK_ERROR
E: [watchdog] [    599710] sendPingMessage:132	Failed send ping message: X_LINK_ERROR
E: [watchdog] [    600709] sendPingMessage:132	Failed send ping message: X_LINK_ERROR
E: [watchdog] [    601708] sendPingMessage:132	Failed send ping message: X_LINK_ERROR
E: [watchdog] [    602707] sendPingMessage:132	Failed send ping message: X_LINK_ERROR
E: [watchdog] [    603706] sendPingMessage:132	Failed send ping message: X_LINK_ERROR
E: [watchdog] [    604706] sendPingMessage:132	Failed send ping message: X_LINK_ERROR
E: [watchdog] [    605705] sendPingMessage:132	Failed send ping message: X_LINK_ERROR
E: [watchdog] [    606704] sendPingMessage:132	Failed send ping message: X_LINK_ERROR
E: [watchdog] [    607703] sendPingMessage:132	Failed send ping message: X_LINK_ERROR
E: [watchdog] [    608702] sendPingMessage:132	Failed send ping message: X_LINK_ERROR
E: [watchdog] [    609701] sendPingMessage:132	Failed send ping message: X_LINK_ERROR
E: [watchdog] [    609701] watchdog_routine:327	[0xd53900] device, not respond, removing from watchdog

 

Hi, Shubha R.,

I am wondering why only the "Human Pose Estimation demo + NCS 2" suffers from present OpenVINO version? Maybe not only this demo, because I haven't tested all the samples... If possible, would you please share more information about the cause?

BR.

Hi

 

I can confirm the same problem ( stuck frequently while loading human-pose-estimation-0001.bi with ncs2 )

    API version ............ 1.6
    Build .................. custom_releases/2019/R1.1_28dfbfdd28954c4dfd2f94403dd8dfc1f411038b
    Build .................. 23780
    Description ....... myriadPlugin

I'm able to run yolo3 on two ncs2 sticks ( multithread) repeatedly..without any stuck error

( meaning I probably have a decent setup )

 

Human pose estimation sample, seems to have some randomness in its behaviour when loading

 executableNetwork = plugin.LoadNetwork(netReader.getNetwork(), {});

It will fail and get stuck, at least one out of three run. No exception just stuck

 

Running the exact same code with ncs1 no load error ....

 

Can't figure out what so special about ( smaller than yolo3 )

human-pose-estimation-0001.bin

human-pose-estimation-0001.xml

 

/JB

 

 

 

More tests

 

Compiled latest inference-engine

dldt/inference-engine

Recompiled human-pose-estimation

Converted input_model human-pose-estimation.onnx

https://github.com/Daniil-Osokin/lightweight-human-pose-estimation.pytorch

 /deployment_tools/model_optimizer/mo.py --data_type=FP16 --input_model human-pose-estimation.onnx --input data --mean_values data[128.0,128.0,128.0] --scale_values data[256] --output stage_1_output_0_pafs,stage_1_output_1_heatmaps

Result, still unstable behaviour frequently stuck on ( no exceptions thrown )

executableNetwork = plugin.LoadNetwork(netReader.getNetwork(), {});

 

Any ideas ?

 

 

 

 

Hi, everyone,

The human pose demo seems only problematic in 2019 R1.1.

When I read Shubha R. mentioned that it is fixed in the next release (and good news, it's available now), I started to suspect that maybe only R1.1 has the problem. Therefore I rolled back to previous installation of OpenVINO (R1.0.1), and the demo run without any problem.

And just as Shubha R. had mentioned in the previous reply, the new release (R.2) has fixed the problem, so just update to the newest version and try the demo again.

 

Dear Tenn, Hian-Kun,

Please definitely report back here if human pose doesn't work for you in OpenVino 2019R2. It should work fine. Please confirm it !

Thanks,

Shubha

 

Hi Shubha,

Sorry for my (previously) unclear post.

When I posted that, I actually have tried OpenVINO R2 and the human pose demo worked perfectly. Therefore I wrote "the new release (R.2) has fixed the problem", but that sentence was after "And just as Shubha R. had mentioned in the previous reply" and it might cause the confusion.

Thank you and the team for the effort. (All I want now is getting NCS 2's temperature, but it is out of the topic here... :-p)

Hiankun

Dear Tenn, Hian-Kun,

Thank you for clarifying ! I'm glad that this is working for you on OpenVino 2019R2.

Shubha

Leave a Comment

Please sign in to add a comment. Not a member? Join today