Fresh trouble with launching example for Intel Compute Stick 2

Fresh trouble with launching example for Intel Compute Stick 2

When I launch security_barrier_camera demo in the OpenVino toolkit 2019.1.144 I get following error:

... loading ...
E: [ncAPI] [    956216] ncDeviceOpen:672	Failed to find suitable device, rc: X_LINK_DEVICE_NOT_FOUND
... some loading ...
E: [ncAPI] [    958244] ncDeviceOpen:672	Failed to find suitable device, rc: X_LINK_DEVICE_NOT_FOUND
[ INFO ] Start inference

The window with a car opens though. It shows FPS ~22, which is different from running the same demo on CPU (with -d CPU).

I've done all the instructions: run the setupvars.sh (vars are set, I've checked), installed all the dependencies and run the install_NCS_udev_rules.sh, as stated in the docs and forum threads. I run the demo with the -d MYRIAD key. Another demo "demo_squeezenet_download_convert_run.sh" runs fine, without any errors. The USB device is shown in the `lsusb`.

1) Why is that error happenning?

p.s. Linux Ubuntu 16.04, OpenVino 2019.1.144, Compute Stick 2,

p.s. The same on Windows 10.

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Thank you for submitting this issue. I validated this in R1 release and i can say that we no longer have this error in the upcoming version of openvino. 

I am sorry for any inconvenience that this causes you.

Thank you for the answer!

While the new release is not published, can I use the NCS2 and ignore that error? It seems that it works anyway. Are there any implications that would impede using NCS2?

There shouldnt be any implication but i would definitely upgrade to the next release of openvino when it is available as there are some significant improvements  along with bug fixes. 

 

Leave a Comment

Please sign in to add a comment. Not a member? Join today