Usage of INT8 Calibration Commands

Usage of INT8 Calibration Commands

Hi,

I tried using one of the argument "--ignore_layer_types".

I used it like --ignore_layer_types Convolution and --ignore_layer_types 'Convolution' and --ignore_layer_types [Convolution] but none of them worked for me. That layer converts to int8. But i want to ignore that and keep fp32 precision for particular layer.

If i am doing something wrong, please correct me.

Thanks,

Puru

 

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Dear pdewan,

I am checking on this. Thanks for your patience !

Shubha

 

Dear pdewan,

Can you kindly attach your model and the command you used ? You can attach it as a *.zip.  If you'd rather PM it privately to me, let me know and I will enable you to do that.

Thanks,

Shubha

Dear pdewan,

We tried --ignore_layer_types  on 2019R3 and it works fine. 

Here is typical usage:

1)	python calibrate.py -c C:\Users\test\Desktop\sample_config\caffe_se_resnext_50.yml --ignore_layer_types "Convolution"

or

2)	python calibrate.py -c C:\Users\akuporos\Desktop\sample_config\caffe_se_resnext_50.yml --ignore_layer_types "Convolution" -cfc

Hope it helps,

Shubha

Leave a Comment

Please sign in to add a comment. Not a member? Join today