Problem with certain input resolutions in R2

Problem with certain input resolutions in R2

Hi,

We have a convolutional network that takes a variable input size.  The original network is created for a specific input size (e.g. 192x192), and before loading the network, a reshape is performed to match the new input size.  We found that when loading the network, the program crashes for certain input sizes.

I have attached code and model files that replicate this problem.  The model file simple2.bin is created for an input size of 192x192.  if the input size is changed to 512x600, it crashes when executing the "ie.load_network()" command.

Please note that this does not happen for all sizes.  For example 512x400 works fine.  This was not a problem prior to 2019 R2 release (2019 R1 worked fine)

 

Thanks
Raghavan

AttachmentSize
Downloadapplication/zip load_crash.zip3.92 KB
3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

One of the suggestions was to use a size that is a multiple of 16.  I tried 512x640, and this failed as well (both are multiples of 128).

Dear Raghavan S,

The fact that it used to work and suddenly doesn't anymore in 2019R2 is definitely suspect. Thanks for attaching your *.zip. Give me a chance to debug this OK ? I promise to report back on this forum and also if there is a bug, I will file a bug on your behalf.

Thanks for using OpenVino and thanks for your patience !

Shubha

Leave a Comment

Please sign in to add a comment. Not a member? Join today