Install prerequisite numpy version conflicts

TCE Options

TCE Open Date: 

Sunday, December 1, 2019 - 12:42

Install prerequisite numpy version conflicts


I get this error 
ERROR: tensorflow 1.15.0 has requirement numpy<2.0,>=1.16.0, but you'll have numpy 1.15.0 which is incompatible.
ERROR: mxnet 1.3.1 has requirement numpy<1.15.0,>=1.8.2, but you'll have numpy 1.15.0 which is incompatible.

When I upgrate to latest numby tensorflow error goes away
and I am only left with : 

ERROR: mxnet 1.3.1 has requirement numpy<1.15.0,>=1.8.2, but you'll have numpy 1.15.0 which is incompatible.

 

WHen I down grade the the version mxnet wants tensorflow complains.
ERROR: tensorflow 1.15.0 has requirement numpy<2.0,>=1.16.0, but you'll have numpy 1.15.0 which is incompatible.

It is sort of a chicken and egg situation 

Am I missing anything. 
Thanks

2 posts / 0 new

Hi, Evren,

Yes, the required library for different framework might conflict with each other due to numpy version used. Do you use both of the framework at the same time? currently the workaround might need to change the numpy version base on the AI framework you are using or about to converted by Model Optimizer.

Leave a Comment

Please sign in to add a comment. Not a member? Join today