Error during compilation

Error during compilation

I'm probably missing something, as i can't get the code to compile if i submit a *.zip file. In my code i need an up do date version of g++ or icpc to support SSE, and maybe that is the problem. I am using something like :$(ICC_PATH)icpc -msse4.2 -O3 code.cpp -o runI have tried both the default makefile and my makefile. Adding "source /opt/intel/bin/ intel64" also doesn't help...PS : Code compiles well with icpc and g++ local on my machineThank you in advance

8 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.


for your last submission, you have this error:
Makefile:3: *** missing separator (did you mean TAB instead of 8 spaces?)

and for some others before, that one:
main.cpp(214): error: identifier "memcpy" is undefined

Apparently some spaces were added in the Makefile before i uploaded it.Regarding the "memcpy" error somehow on another machine it compiled without "string.h" header.Everything is ok now, thank you :)

I'm getting this error :double free or corruption during program execution when i upload file on intel machine but when i run the same program on my machine (i'm using VS2008) it executes correctly. I googled this error and it is thread related (i think). Can anyone help me with this? I don't understand why do i get this error ont intel machine but not on mine. Is it because OS are different?


I have the same error as shakal187 : "error during compilation.".
Couldn't we get the output of the compilation, so that we can have a clue of what's going on on the remote machine?

Thanks in advance for your answer.


I've discovered the problem. String is not thread safe and because of that, it can't run the program. But in our case, those strings in threads are not used for changing them, but only to get their lenghts and read characters from them... There is no chance for unsafe thread handling with them. IS this because of gcc compiler? I'm still unable to compile my code with intel compiler on their machine... Something is not set up right in Makefile....

Tonight, my coleague and me, had the same problem on Fermi machine so I can say that stl::string is not thread safe even for reading couse after we implemented our class string2 everything worked fine.

This string issue was something painful for us too.We decided to limit their utilization to the minimum, and us char * when possible.And now everything work fine.

Leave a Comment

Please sign in to add a comment. Not a member? Join today