Cannot open source code when attaching to process (OK if I start program from de debugger)

Cannot open source code when attaching to process (OK if I start program from de debugger)

Hi,

I'm running IDB 13.0 in Ubuntu 12.10 and I found that if I start my code from the debugger I can open the source code without any troubles, but if I start the code (which waits in a loop) and then attach to it from inside the debugger, then I cannot see the list of the source files.

I open the code and the debugger from the same directory, so finding the files should not be a problem, but I don't know what could be happening. I include screenshots in case they can be of interest.

Any suggestions?

Thanks,

Ángel de Vicente

AttachmentSize
Downloadimage/png setting.png259.49 KB
Downloadimage/png source-files.png61.84 KB
Downloadimage/png no-sources.png36.65 KB
4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

I add a couple of new screenshots to show the behavious:

Attachments: 

AttachmentSize
Downloadimage/png idb-args.png270.41 KB
Downloadimage/png attach.png175.04 KB

Hello,

sorry for the delay, our notifications were down. I can confirm this problem for Ubuntu 12.04. Older Ubuntu versions seem to work well. I've escalated this problem to debugger engineering (DPD200240305). As soon as I hear back from them I'll let you know.

Best regards,

Georg Zitzlsberger

Hello,

the solution is to set /proc/sys/kernel/yama/ptrace_scope to 0.

Please be aware about potential security implications. See more information here:
https://wiki.ubuntu.com/SecurityTeam/Roadmap/KernelHardening#ptrace_Prot...

Best regards,

Georg Zitzlsberger

Leave a Comment

Please sign in to add a comment. Not a member? Join today