No symbol xxxx in current context in my c++ program

No symbol xxxx in current context in my c++ program

Hi,

I'm using icc17 update 4 on linux, windows and macOS. On linux (only) I'm having trouble with gdb-ia not being able to see certain local variables. If I modify my code sometimes variables that weren't available become visible and vice versa. There is no discernible pattern to that.

I have studied this page to no avail https://software.intel.com/en-us/node/682630. That page is a little confusing though as it's not really clear if -debug extended is the maximum level of debug info our not since it makes the cryptic comment that it can be combined with inline-debug-info, semantic-stepping and variable-locations. How does it get combined?

I have tried -debug inline-debug-info,semantic-stepping,variable-locations,extended and that did not help my problem. I have also tried:

  • -g
  • -g -debug extended
  • -g -debug inline-debug-info,semantic-stepping,variable-locations,extended
  • -debug all
  • -g -debug all

Specifically the problem shows up in regular method bodies (not inlined) and the variable in question can of any type. Other local variables are "available".

This doesn't seem to be a problem with small or example programs or I would attach an example.

Cheers,

James 

Thread Topic: 

Bug Report
1 post / 0 new
For more complete information about compiler optimizations, see our Optimization Notice.