Cannot run the crown scene [SOLVED]

Cannot run the crown scene [SOLVED]

Hi,
I just downloaded the latest Embree code. I can run the cornell box and other scenes. When I try to run the crown scene, it starts but after a while gives me this error.

Error: aligned memory allocation failed.

My machine specs:
OS: Windows 7 64-bit
CPU: Intel Xeon CPU E5507 @ 2.27 GHz,
RAM: 4 GB

I stepped into the code in the debugger to see the exact place where this error popsup. It is line 70 platform.cpp the size for allocation is 701125056 which returns this error.

Is it something to do with the amount of memory left? I have around1.9 Gb of RAM freeif I dont run embree. When embree was run in the debuggerat the time of the error,I had 915 Mb free. I think it is probably due to the large size of crown scene? What should I do to make it work I need to see the crown scene in action.

5 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.
Best Reply

The issue is caused by the Spatial-Split-BVH builder that is enabled for the crown by default, it allocates much memory. There are different solutions to the problem:
1) Disable the spatial split builder in the crown/crown.ecs file, by changing the line -accel bvh4.spatial to -accel bvh42) Increase the swap file on your harddrive (http://windows.microsoft.com/en-US/windows-vista/Change-the-size-of-virtual-memory)Also make sure you were building the 64 bit version of Embree.

Hi Sven,
Thanks for your reply.

I build the x64 version and it ran but the glut window was never shown.The cmd prompt kept on screen and it sucked the entire 4Gb RAM to a point that my machine hanged and I had to hard reboot.

So then I tried the -accel bvh4 with the win32 version, that fortunately ran but I could not see anything only white screen the title shows 0.04 fps and time is 24051 ms so does this mean that to run this model, i need a better processor than Xeon or multiple Xeons?

Why does it take such huge memory for building the bvh, the crown model is around 160 mbs only?

I had no problems to run the crown model with only 2GB of memory, when using the -accel bvh4 option. With this option the model runs in 64 and 32 bit mode.Try to run the 64 bit version with the -accel bvh option. Best perform a rebuild of the entire project.

Hi,
Thanks, x64 works fine now with -accel bvh option butx86 version crashes.I get around 1.38 fps @ 754 ms per frame for x64 version.

Pretty cool.

Thanks for the help. It is solved now.

Leave a Comment

Please sign in to add a comment. Not a member? Join today