Does SDK work on Windows Vista Starter.

Does SDK work on Windows Vista Starter.

Hi, I have just joined the developper program. Want to know if SDK installs and works fine under Windows Vista Stater OS. I saw "Appup beta" doesn't work under vista. Is there such restrictions for SDK? Thanks, DS
10 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

I suggest you for not using Starter edition of any Microsoft OS'es. There's only a few users were using it and there's many limitations such the number of programs you run, maximum RAM amount, etc. Even Visual Studio can't be installed in there. You should upgrade to any Windows edition instead of Starter Edition


officially supported are these OS for the SDK:

Intel® Atom™ Developer Program SDK Beta release has been tested on the following operating systems:

Microsoft* Windows XP Professional 32-bit with SP3 (English Version)
Microsoft* Windows XP Home 32-bit with SP3 (English Version)
Microsoft* Windows 7 Starter 32-bit (English Version)
Microsoft* Windows 7 Home Basic 32-bit (English Version)
Microsoft* Windows 7 Home Premium 32-bit (English Version)

Best Regards,

Andre B.

Intel® Atom™ Developer Program


I may be able to add some more to that.

While the App Store (AppUp) will not run on Vista, the SDK is usable but not supported. I do not recommend you try to develop ATOM applications on Vista. In certain situations I have developed a few ATOM applications on my Vista laptop and there are a few things to watch out for:

1.) When including references to system DLL's, make sure they are not packed with your MSI installer.
2.) Beta test you application on a Windows XP / Windows 7 test system

Best of luck

Thanks for your comment.
I tried to install SDK on Vista. It didn't. So i have to stop working on Vesta.
- DS


You could not install the SDK onto Vista? What was the error? I ask because I have never had a problem in the past.

Which edition of Vista are you using? I'm using Vista Starter. Starter edition doesn't support many things. The erro massage i have got is "Thie Windows installer service could not be accessed. This can occur if windows installer is not correctly installed. Contact your service personal for assistance". FYI, any other sofware installs and works just fine.


Vista Ultimate on both laptops. Have you tried right clicking on the MSI and choosing "Run as Administrator"?

Yes, i tried to install as administrator. Everythigh ran fine but i don't see the installed directory in c:\program files\intel..... Neither there is a shortcut created in desktop nor a program item created in start->all programs.
In Windows XP it gets installed nicely.
- DS


I downloaded the Vista Starter trial and you are correct. The limitations of this edition prevent the SDK from working correctly. I suppose that is to be expected since the AppUp store is not supported on Vista at this time.

Perhaps run a trial of Windows 7 for now?

Download Windows 7 Trial:

More details on Vista Starter:

Leave a Comment

Please sign in to add a comment. Not a member? Join today