Launching Browser

Launching Browser

In our application, we want to provide online help and needs to open browser. In the test environment it works fine and launch the browser with ShellExecute function but when launched from AppUp, application is receiving access denied to launch the browser. Rest of the application runs OK. Has anyone experienced this issue? Any help is appreciated.
12 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

You may solve this by providing an application manifest that requires elevated user permissions (requireAdmin for example). This should alleviate the issue you are experiencing.

You pass path to browser or URL to open when you call ShellExecute ?

Update: A quick test reveals that the privilege level "asInvoker" may suffice for your purposes as well. Best of luck.

Thank you for the responses. I tried both as "asInvoker" and "requiredAdministrator". It works fine in the debug mode and I still have problem when it is launched from AppUp with production GUID. I tested on my beta test machine where I have AppUp. It works just fine when I don't use the SDK and run outside the AppUp. I am going test more and see if there is a work around.

Try launching the AppUp client as Administrator, I am curious if this solves the problem.

Thank you Brain. It doesn't seems to make a difference.

I request any one from Intel to comment on this if AppUp suppresses launching another application when using ShellExecute.

Hi dmitry-rizshkov,
I do pass URL to open when calling ShellExecute.

what version of the IADP SDK do you use?
for now i advice you to debug your code and Check the return value of The ShellExecute function,which will indicate the
observed error.for error Codes see:

As for passing a URL. Something like this ought to work:

ShellExecute(NULL, _T("open"), _T(""), NULL, NULL, SW_SHOWNORMAL);

We are using the same syntax but we are getting access denied error.

If ShellExecute is returning code 5 (access denied), you can easily catch that condition and use CreateProcess or WinExec in those cases. I did a quick test under Windows 7 and while ShellExecute failed, CreateProcess worked correctly. Please let me know if you have any further difficulties.

Leave a Comment

Please sign in to add a comment. Not a member? Join today