Recieving ADP_NOT_AUTHORIZED even when using a valid genereated ui

Recieving ADP_NOT_AUTHORIZED even when using a valid genereated ui

hi.. in our program while launching application we get ADP_NOT_AUTHORIZED from "ADPW_IsAuthorized" function, ADP_Initialize returns true before calling this.. we are using a valid GUID. can ony sense what could be the reason? Thanks, Manish
17 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.


Adding to Manish's info, When I launch the app from AppUp, "Not Authorized to run" message popsup.

Can anyone help Manish is addressing this issue?


Hi Praveen,

"Not Authorized to run" is my message give when i recieve ADP_NOT_AUTHORIZED from "ADPW_IsAuthorized" function..

after that i exit the application...


If you are running your program locally using ATDS, use the DEUG GUID

If you are using beta testing to run your program, you will need to use your assigned GUID.

Please let me know how this turns out for you, I am always happy to help further.

Hi Brian,

we are using the assigned GUID.

and using ATDS in this case doesnt gives an error at our side..

yet it gives and error in beta testing..


Hello Brian,
sorry for the late ansver.

The next day we have check the MSI again and it was now the new sources.

For next time I will number the file names.

Thanks for the tip.

I have this problem, too. My application was rejected, due to the reason "ILU03 - Application launch".
"Additional Comments: Application does not launch from AppUp. The following error message is displayed: Cannot start Qwerty Quartet application! The application is NOT authorized to run…" (that is, the message displayed when ADP_IsAuthorized() returns ADP_NOT_AUTHORIZED).

When I used the debug ID, everything was OK, then, therefore I thought that just changing the GUID with the correct one in the release version, before submitting would be enough. But, a week after submitting the app, I received the 'validation failed' email. Now, I've tested it using 'Beta testing' feature... with no luck. ADP_NOT_AUTHORIZED... I really do not know why.

Thank you in advance,

@Thomas: Excellent to hear, glad you are back on track

@andre: It sounds as if you used the DEBUG GUID or an invalid GUID in the MSI you submitted. Remember, the debug GUID is only for testing locally using ATDS. You need to insert your assigned GUID when building for production (and submitting through the dashboard). When you upload next, be sure to change the MSI filename slightly as Thomas did to avoid caching of your MSI by the back end server.

Thank you for the reply, Brian!

The production GUID was inserted into code, before final (release) compilation, just before building the MSI package. Is there a place inside the MSI to insert the GUID, too? And is there any naming convention for the executable? I mean, if the application's name, in the Store, is 'QQuartet', but the executable file is named slightly different, is this leading to an authorization problem, like the one I've mentioned in the post?

Here's a little 'history' of submitting the application:
- my application was initialy named 'Drums', but, because it was a too common word, I've changed it into 'Qwerty Quartet'.
- on 13th of April or so, I've uploaded the MSI package and submitted the application (without beta testing), under 'Qwerty Quartet' name.
- one day later I've realised that it won't install silently and, therefore, will be rejected. So, the validation being in progress, I've sent a mail to the validation team, asking them to cancel the validation, because it wouldn't have passed the guidlines anyway. Meanwhile, I've submitted the app with another name (again, without beta testing), 'QQuartet', and, obviously, with another product GUID.
- one day later I've received a reply to the mail, from the validation team, saying that 'Qwerty Quartet' is rejected, as I've asked.
- yesterday I've received the 'rejected application' mail (Failure Reason: ILU03 - Application launch) - described in the post above.

Now, I've tried to get the application work in AppUp (beta testing, and the tester would be me), but without succes. I've tried with 2 email addresses (choosing 'United States' in location field, as I've read in an article on the site). I'm using Windows XP (on a laptop without atom processor).

Also, here are some lines of code from the source of the app:

#ifdef _DEBUG
#ifndef _DEBUG
ADP_APPLICATIONID myApplicationID = {0xA816D783,0xF75C4F84,0x96FDD9CC,0xF82FE022};

if (ADP_IsAuthorized(myApplicationID) != ADP_AUTHORIZED ) {
MessageBox(NULL, L"the message", L"err", MB_ICONERROR);
exit (1);

Thank you for the patience of reading this long post :)

The same is here..

here is my code snippet..

We are not able to get rid of the error....for no authorization..

extern "C"
IADPW_API ADP_RET_CODE __cdecl ADPW_IsAuthorized(int i)
#ifdef _DEBUG

if( ret_code == ADP_AUTHORIZED )
//AfxMessageBox( _T("Hello World \n") );
AfxMessageBox( _T("Not authorized to run \n") );
//exit (1);
return FALSE;




I think before calling ADP_IsAuthorized you should initialize the runtime by calling ADP_Initialize() and check it's return value
to see if it success("ADP_SUCCESS") or not .also you should always call ADP_Close() before the application exits,whatever the reason to exit was,to ensure an orderly teardown of the runtime.


we do call the init().

here is how it is done
ADPINIT adpInit;
ADPAUTH adpAuth;
adpInit = (ADPINIT) GetProcAddress(hinstLib, "ADPW_Initialize");

// If the function address is valid, call the function.

if (adpInit)
ADP_RET_CODE ret_code;;
ret_code = (adpInit)();
if (ret_code != ADP_SUCCESS)
CString strTemp;
strTemp.Format( _T("FAIL: ADP_Initialize failed with error code %d \n"), ret_code );
//exit (1);
return FALSE;
//ADP_IsAuthorized is called here


Hello! Try this, it worked for me now, at least while beta testing :)

ADP_RET_CODE ret_code;
ret_code = ADP_Initialize();
switch( ret_code ) {
case ADP_INCOMPATIBLE_VERSION: MessageBox(NULL, sz_adp_inc_version, L"", MB_ICONERROR); break;
case ADP_FAILURE: MessageBox(NULL, sz_adp_failure, L"", MB_ICONERROR); break;
case ADP_NOT_AVAILABLE: MessageBox(NULL, sz_adp_not_available, L"", MB_ICONERROR); break;
} ADP_Close(); exit(1);
// now check if the application is authorized to run.
#ifdef _DEBUG
#ifndef _DEBUG
const ADP_APPLICATIONID myApplicationID = {{0xA816D783,0xF75C4F84,0x96FDD9CC,0xF82FE022}};
ret_code = ADP_IsAuthorized(myApplicationID);
switch(ret_code) {
case ADP_FAILURE: MessageBox(NULL, L"Communication error...", L"Error!", MB_ICONERROR); break;
default: MessageBox(NULL, sz_adp_not_authorized, L"Authorization error", MB_ICONERROR);
} ADP_Close(); exit(1);
// that's it, your code goes here: ...

Don't forget to change the GUID with your product GUID, {{..., ..., ..., ...}}.

TIP: after adding you as a beta tester on the site, launch "AppUp", sign in, and then start your application (the 'release' executable), from the local file system. You don't need to upload and download it every time you change some code and recompile.
Let me know if it works :)



>> after adding you as a beta tester on the site, launch "AppUp", sign in,

Can you please help us with these steps in some detail

1. How do we add us as a beta tester
2. Once AppUp starts, we need to sign in. Do we need to register another account here which is different from Step 1.

Thanks in advance

Hello Manish,

Please see

There is currently a known issue with receiving BETA email invites that we are investigating. Please see

You should still be able to test. For the moment, only the invitation email seems not to be working, but the application does appear under pending downloads when the beta testers login to the AppUp(SM) Center.


Hal G.
Technical Support Team
Intel® Atom™ Developer Program
Intel AppUp(SM) Center

Thanks Hal,

We did make some progress now.

- we are able to create a beta-testing account on Intel AppUp Center and sign-in successfully.
- the application is listed as available for download and we can start the download.

However, there are problems after this (we are located outside US/ Canada - could that be the reason)

- everytime we try the download fails with this message:

"Oops! Something weird happened and we couldn't complete your request. Please try again. If you continue to get this error, please contact support."

However, since this our own application, we dont really need to download it. Running it from the local machine WORKS!
Thanks a lot !

Hi Manish,

Thank you for your reply.

Starting March 31, 2010, the Intel AppUp Center Beta (Windows* and Moblin™ 2.1) is also available to consumers in Austria, Belgium, Bulgaria, Cyprus, Czech Republic, Denmark, Estonia, Finland, France, Germany, Greece, Hungary, Ireland, Italy, Latvia, Lithuania, Luxembourg, Malta, Netherlands, Poland, Portugal, Romania, Slovakia, Slovenia, Spain, Sweden and the United Kingdom, hence it is no longer only for US and Canada.

The error you are getting is not really related to you not being in US or Canada. Beta testing does not consider your location as far as know, provided you are in a country where you can use the AppUp(SM) Center.

If you are getting any error in downloading and launching the application from the AppUp(SM) during beta testing then this might be an issue. If you submit your application, it will get rejected. Please revise your code and check that the paths and targets are properly defined. Refer to this link for more information of configuring paths and targets:


Intel® Customer Support
Intel® Atom™ Developer Program
Intel® AppUp(SM) Center

DG Rooven

Leave a Comment

Please sign in to add a comment. Not a member? Join today