adp not available

adp not available

Hello, since today during the beta test we get always the error message "ADP not available". This occurs with all of our software products, also with programs that already worked. Is there a problem with the Intel server, have you made changes or what can be the reason? Thank you Thomas
10 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.


A few questions and possible answers:

Are you running the application from AppUp? Or is this ran locally (debuggin)?

If you are running this after downloading from the AppUp client, ensure that you do not have the Intel ATOM SDK installed. The ATOM SDK and AppUp client do not operate correctly when installed together on the same machine.

If you are running locally (debugging), ensure that you have ADTS running. If it is running, does it produce any output when you attempt to start your application.

Basic questions:

Are you running the latest ATOM SDK and ADTS?
Have you rebooted the machine?

Hello Brian,

1. We making the beta-test from AppUp!
2. We use the SDK 0.91.
3. Until now we don't need the ATDS (?) for testing. Today we check this also with running ATDS, but there is no difference.
4. We have install the AppUp and SDK together. Until now its work without problems.
5. The only message is "ADP not available".

We will check this again with deinstalled SDK only with the AppUp.

Thank you

Hello Brian,
now we uninstall the SDK from the virtual machine. The error message "ADP_not_available" is still displayed.

We check this now also on a real atom-netbook with AppUp. -> We receive the same error message!

The software we've tested some time ago without error shows the same behavior. Similarly, the software has been tested by Intel already successful.

What can be happend?


would be very happy if someone could help me.

Or at least a short post when I can rake with an answer.

Thank you


Have you check to be sure you virtual machine is a plain install of your target windows operating system and the AppUp client? It is critical that it is a fresh install, as one that has had applications installed and uninstalled may have DLL / Library differences.

Another item to look at is ATDS. Try running your application on your development computer using ATDS. If this yields the same error, please post the results from the ATDS window.

Hello Brian! Hello Cemal!

We hope we have fixed the adp problem now. With the debugger we found now a inconsistence. We hope this fix the problem. However, we still is not clear why the setup worked for some time...?

Whom should I contact to update the setup version of the programs "abylon SHREDDER" and "abylon FILEEX"? These are currently in validation.

Thank you a lot.

Best regards


That is great news. Regarding your apps in validation, i would send an email to support who may route it to the validation team if needed.

Hello Brian,
thank you.

Cermal wrote:

Your application is in Binary Validation, it will be in a lock status. For that reason, you will have to wait for the application to come out of this status to be able to make changes.

Make it sense to write also? Or is Cermal from the validation team?

Thank you


No he is not from the validation team, and he is correct. It is standard to have to wait for the validator to release the entry. However, in some circumstance they may release it sooner with an email to support. That is up to them to decide.

Leave a Comment

Please sign in to add a comment. Not a member? Join today