ADP_IsAuthorized() always returning "ADP_AUTHORIZATION_EXPIRED"

ADP_IsAuthorized() always returning "ADP_AUTHORIZATION_EXPIRED"

Hi, I need a bit of help here, I've tried every sample binary and source code included with the SDK both 0.91 and 0.92 and all of them are returning "ADP_AUTHORIZATION_EXPIRED" when ADP_IsAuthorized() is called. I've tried testing on 2 different machines and got the same results. I've even tested them using both vs2008 and vs2008 express both still with the same result. So I would like to kindly ask 1. Currently I'm in a country that isn't supported by Intel AppUp program. Could that be reason that ADP_IsAuthorized() is always returning "ADP_AUTHORIZATION_EXPIRED" ? 2. Since the sample source code are using the "ADP_DEBUG_APPLICATIONID" id which expires in 2020, I assume that "ADP_AUTHORIZATION_EXPIRED" in my case is actually from a different problem, not the app id expiring? Thanks! Regards.
10 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hey guys, a quick update on the issue. It seems that the SDK doesn't support localization versions of Window XP or Win 7 that uses a different date format. Intel says this issue will be fixed in the next release, however for anyone who is having the same problem. Here's my work around after knowing the issue with the SDK.

Problem - SDK returning "ADP_AUTHORIZATION_EXPIRED" when it shouldn't

Fix - Open Window Control Panel --> Open Regional and Language Options --> Open the Advance tab --> in the Language for non-Unicode programs drop down box change it to "English(United States)" --> Restart your PC and your ready to go!


Thank you for the feedback, this is a great example of us developers helping to refine the beta program.


Although I am not on the SDK Development team I am happy to offer some assistance:

1.) I know several developers in currently unsupported countries and they do not report this problem.

2.) If you are passing over the ADP_DEBUG_APPLICATIONID, then it would not be the root cause.

Here are my suggestions (Some of which you have likely tried):

1.) Uninstall AppUp if it is installed (then reboot)
2.) Verify that your linker/compiler settings are pointing to the latest SDK. (Mixing an older version of the SDK with a newer ATDS is problematic)
3.) If possible, post your code here for review

Thanks for your help Brian, I really appreciated.

1.) Before starting development I read all the forums and documents so from what I understand is that installing the SDK and AppUp in the same development system is a no no. So I didn't install AppUp on my system.

2.) I'm running the "AdpCSample.sln" (I've tried all the samples and binary and all return "ADP_AUTHORIZATION_EXPIRED") sample source code included with the SDK which is located at "C:\Program Files\Intel\Intel Atom Developer Program SDK\0.92\Samples\c" which all the samples projects are linking against the headers and lib using "../../../included" and "../../../lib" so hopefully there shouldn't be any problems with the linkers.

3.) Sure, the code I'm testing is the "AdpCSample.sln" without any modification using the AdpHelloWorld as the startup project.

int _tmain(int argc, _TCHAR* argv[])
// Debug application ID

// API return code
ADP_RET_CODE ret_code;;

// Intailize the adpcore data structure data structures, and determine
// whether the system is compatible. It must be called before calling
// any other call to the adpcore.
ret_code = ADP_Initialize();
if (ret_code != ADP_SUCCESS)
printf("FAIL: ADP_Initialize failed with error code %d \n", ret_code);
exit (1);

// Check the application is authorized to run.
ret_code = ADP_IsAuthorized(myApplicationID);

// TODO: Application specific stuff goes here
if( ret_code == ADP_AUTHORIZED )
printf( "Hello World \n" );
printf( "Not authorized to run \n" );
exit (1);

// Cleanup the adpcore data structure, and shutdown connections used by the adpcore.
ret_code = ADP_Close();
if( ret_code != ADP_SUCCESS )
printf("FAIL: ADP_Close failed with error code %d \n", ret_code);
return 0;

I've also tested this on all of my 3 system (all with window XP home and are not Netbooks) with only the SDK install and not AppUp, all are returning "ADP_AUTHORIZATION_EXPIRED".

I just asked a colleague which is in the UK tested the sample binary included with the SDK at "C:\Program Files\Intel\Intel Atom Developer Program SDK\0.92\bin" by running runATDS.bat and then AdpHelloWorld.exe strangely enough, it does not return "ADP_AUTHORIZATION_EXPIRED" and the program ended correctly.

Could this be because some kind of router or isp conflict issues...?


It seems you have been quite thorough, the code "should" work as is (as I am sure you know by now). I doubt that it is an ISP issue, although one cannot rule out an aggressive HTTP cache system. A tool such as Fiddler may yield some insight on whether the response is being cached. Is there any chance of taking one of your computers to another network to test?

Aside from that being the culprit this may be something at the SDK level. I would suggest that you send an email over to Support using this link ( and reference this thread.

Please do share the outcome, I am happy to help whenever possible.

EDIT: If you don't mind, please attach the binary here so i may review.

Thanks Brian,

Here a quick update so far, I've been contact by a really helpful Intel employee which is helping me with this issue. So far I've

* I've asked 2 colleague in Thailand (the current country I'm in) both running Win7 and using different ISP to download the 0.92 SDK and run the sample binary included with the SDK at "C:\Program Files\Intel\Intel Atom Developer Program SDK\0.92\bin" by running runATDS.bat and then AdpHelloWorld.exe . Both of them are returning "ADP_AUTHORIZATION_EXPIRED" error.

* I've tried changing the "Data & Time" in Window to year "2009" and changing the Time zone in Window to - "Central America", "Central Time" and "Mountain Time" (and many more) all still result in a "ADP_AUTHORIZATION_EXPIRED" error.

At the moment, I'll give it a rest for a few days until I can think of some way to diagnose the problem.



Redownload the atom sdk.Start a sample project.Test the sdk again.Remember to properly set the llinker setting.Try this with both sdk one by one

Any luck Harvey?

Thanks for your help Brian, I haven't been able to fix it yet but I've setup a test case and send the error and log info to Intel Support. Will find a Win-7 System and test the binary on it, will let you know what happens.


Leave a Comment

Please sign in to add a comment. Not a member? Join today