Platform Analyzer: No OpenCL context track in trace

Platform Analyzer: No OpenCL context track in trace

Hi,

when trying to profile our OpenCL application using the GPA tools, I do not get OpenCL context tracks in the trace file. However, there is a "GPU: UNKNOWN" track. Is there an environment variable or GPA option I'm missing?

  • OpenCL Configuration Utility is switched to profile mode, UAC is off
  • Environment variables "CL_CONFIG_USE_GPA" and "CL_GPA_CONFIG_ENABLE_API_TRACING" are set to "True"
  • Our application is a console application and does not use Direct3D or OpenGL
  • All tracing options and domains in GPA monitor are selected

"About" information from GPA monitor:

Windows 7, 64-bit DEP enabled
Num Processors: 4
Memory: 8011MB
System BIOS: Intel Corp. RKPPT10H.86A.0023.2013.0529.1711 (05/29/2013)
Video BIOS: 11/23/20
Driver 0:
Device: Intel(R) HD Graphics 4000
Provider: Intel Corporation
Date: 5-7-2013
Version: 9.18.10.3165
VendorId: 8086
ProductId: 166
Stepping: 9
Supports GPA Instrumentation
GPA install directory: C:\Program Files\Intel\GPA\2013 R2\
GPA version: 13.2.200837
Current user is in Administrators group: YES
Current GPA 2013 R2 (13.2.200837)

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Lukas,

Im really sorry for the delay. I have forwarded your question to one of our developers. We should have an answer for you soon.

-Eddy

Hi Lukas,

I've responded with a private message.

-Eddy

Hi Lukas,

I'm sorry but GPA doesn't always have propper support for OpenCL. There is nothing to do with it right now.

Regards, Stas.

Leave a Comment

Please sign in to add a comment. Not a member? Join today