GPA not showing Media Metrics

GPA not showing Media Metrics

Hello,

GPA is not showing any of the Media Metrics in either System Analyzer or "Analyze Application". See the attached screenshot.

My system:

Current Graphics Performance Analyzers 2017 R1 (17.1.308306)
Windows 10 build 14393, 64-bit DEP enabled
Device: Intel(R) HD Graphics 4000, Version: 10.18.10.4425

AttachmentSize
Downloadimage/png gpa.png29.06 KB
Downloadimage/png media.png14.78 KB
10 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Shuo,

I'm sorry you are running into issues.

Thanks for the image attachments and details you have already provided.  What process are you trying to inject into when you run into this issue?

Your 2nd image makes it seem like you are attempting to utilize the Media SDK, it that correct?

I do have a suggestion straight away that may help you out - upgrading your gfx driver.  Let me know if that helps at all.

Hi Ryan,

Thanks for the response!

I was trying to monitor Media Engine utilization of my application. The 2nd image is to show I have Media SDK properly installed.

I tried just using the GPA System Analyzer, and also tried injecting into a media player (e.g. VLC, MPC-HC). In either case I couldn't get the "Media Metrics" to show up.

This machine is already running the latest driver available for the Intel HD4000. However, I ran into the same problem on another machine with the Intel Iris 540 (a Surface Pro 4) running the latest driver (15.45.16.4627), too, so that seems to rule out driver issue.

Hi Shuo, 

Thanks for the detailed report.  It looks like there may be an issue in our metrics framework for media metrics at the moment.  I have let our platform enabling team know and hopefully can have a response for you soon. 

System View should be the best way to get media metrics, but as your picture showed, they are not there for you. 

Thanks,

Seth

Hi Shuo, 

Got a little bit more information for you and a couple workarounds:

1. Turn on ETW media collection by checking the "Collect DMA packet type" in graphics monitor -> Profiles -> Tracing tab

2. Disable non-Intel GPUs within the system. 

Let me know if those work!

Thanks,

Seth

 

 

Hi Seth,

I tried what you suggested but had no luck:

1) My system had no non-Intel GPU

2) It seems that I couldn't turn on the "Collect DMA packet type" option. when I click on the check box, a dialog box pops up saying a restart is required. If I click yes, after rebooting the system, the checkbox is reverted to unselected state. If I click no then click Apply, the check box seems to stay checked, but if I close the Graphics Monitor window then re-open it, the checkbox again becomes unselected.

3) Other checkboxes like the "View fine-grained system-wide GPU metrics" doesn't have this problem, i.e. they stay selected even after the window is closed.

4) Just to make sure, I tried the System Analyzer anyways, but it had no change (i.e. still no Media Metrics).

 

Hi Shuo,

I have seen this new issue you are describing as well and have passed it off to our engineering team.

Looking ahead to when we have a fix - are you able to use a machine with an Intel specific GPU to gather media metrics?  

Best Reply

Hi Shuo,

I have a workaround for you that should resolve your issue as long as you are comfortable enough to use the registry editor.

1.  Hit Win+R on your keyboard to bring up the Run command dialog

2. Type 'regedit' in the text field (no quotes)

3.  When the window appears, browse to HKEY\Software\Intel\

4.  Right click within the Intel folder and go to New -> Key

5.  A new folder should appear within the Intel folder - name the new folder 'EventTrace' (no quotes)

6.  Close the regedit window

 

After this, re-enable the 'DMA Packet Collection' option from the previous posts and restart your computer.  Once restarted, check the DMA checkbox to make sure it is on (it should be).  From here you should be able to open up System Analyzer and see a media metrics section.

NOTE:  If you are working on a system with no Intel based GPU in at all you may not see the Media metrics section due to 3rd party library support.

I just tried this workaround on a system with only an Intel based GPU and also on a system with an Intel and a 3rd party card and I could see the Media metrics section in SA.

Hi Ryan,

You probably meant HKLM (HKEY_LOCL_MACHINE) by saying HKEY but otherwise it worked for me. Thanks!

 

 

Yes I did :)

Glad it worked for you even though I typo'd.

Leave a Comment

Please sign in to add a comment. Not a member? Join today