Using Frame Analyzer on UE4 project: Unable to determine frame file API

Using Frame Analyzer on UE4 project: Unable to determine frame file API

Greetings.

Following this tutorial I'm unable to check the captured screenshot using Frame Analyzer. I've pretty much followed the tutorial up to that point. Any pointers here?

Thanks in advance.

AttachmentSize
Downloadimage/jpeg GPA_error.JPG53.31 KB

Zone: 

Thread Topic: 

Help Me
18 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Andres,

Sorry you are running into issues.

When you say you are unable to check the screenshot, are you seeing an error of any kind when you try to open the frame?

Also, if you could provide me with your 'About details', that would also help.  

To get those (assuming you are on Windows) - Make sure Monitor is running -> Right click on the sys tray icon -> Click on About -> Either copy n paste the info or click on 'Save as'

Thanks for your reply, Ryan.

Yes, I'm seeing the error displayed in the attached image. In case you couldn't see it, it just says "Error: Unable to determine frame file API", but nothing else. Is there any detailed log dumping somwhere? Log directories inside Documents/GPA don't seem to have enough data for me to tell you if there's any other underlying error that may be causing this.

As for the "about details", of course, here you go. Only thing to note is that I'm running a Bootcamp installation on a Mac. Have you guys had any reports on issues when working in such setup?

Thanks in advance.

 

 

 

Attachments: 

AttachmentSize
Downloadtext/plain monitor_details.txt594 bytes

Hi Andres,

Ah yes, sorry about that, I did see the error in your image, but then immediately forgot it.  I may need more coffee :)

Also, thanks for the extra info!

As for Bootcamp, I have not heard of this particular issue happening, but I have heard of customers having issues when running GPA on Windows through Bootcamp.  We also don't officially support running a Bootcamp'd version of GPA - so running through Bootcamp may be causing an issue here.  Is there a reason you are not able to run our Mac version of GPA?

Something that may help would be to update your gfx driver.

Out of curiosity - which Unreal engine are you running with?  I took a quick look at that tutorial you linked to and didn't see a project link to download (the coffee could be failing me again).  If you are able to share the project you are using I can fire it up over here to see if I run into the same issue.

Thanks for your reply, Ryan.

No particular reason besides me having to work on Windows for our current project and this being my work station. I could try to do the capture in my personal Windows machine to confirm (or discard) that running GPA on Bootcamp is the actual issue. Will try updating the driver as well. I'm afraid I can't share the project I'm working on (you're not missing coffee on this one, the tutorial isn't referencing any specific project ;) ), but then I could try this in an isolated project. Let me get to it.

As for my Unreal Engine version, I'm running 4.15.0, compiled from source, as I need PS4 support (which isn't available for OSX)

Hi Andres,

Yes, if you see the same issue running on a Windows based PC I would like to know.

Again, if you can share the project I can try on my side.

Hello, Ryan.

Did a test with a build made from the UE Rolling game template (didn't add any custom behavior, asset, or anything). Still the same error, so I'm prone to think it may be my running a Bootcamp'ed GPA. I'll get back when I try this on my Windows machine.

Thanks in advance
 

Hello, Ryan. Sorry for the delay.

I tried to make a build the scene in my Windows-based PC, but as soon as I link the executable to the GPA, it will crash the process. Opening the build without GPA does not crash the game. Is there any log I can provide to trace the cause of this crash? Or maybe does it have anything to do with my machine specs? For the record, is a Lenovo g410, (4th Gen Core i5 2.5GHz, 8 GB RAM, dedicated AMD Radeon 8500M 2GB VRAM).

Thanks in advance.

Hi Andres,

No problem with the delay.  That doesn't sound good, that you are crashing.

For logs, you can look in your Documents/GPA/ folder.  In there, there is a Dumps as well as a Logs folder.  Each of those folders may have a log that has been kicked out.  I am hoping you will be able to attach both of the files here.  Also, could you provide the GPA About info for your Windows PC?

Are you able to share you specific Unreal project at all?  I remember you mentioning it was just a basic Unreal scene, but there could be something else.  I created a basic scene on my end and I can inject into it.

The one thing I can think of off the top of my head is that the Unreal projects do not use the DX12 API by default.  You need to add a '-d3d12' flag to run with that API.  If you try to connect GPA using DX12 and Unreal using its default DX11, you will see  issues.

Thanks for your reply, Ryan.

I'd like to clarify something about my basic project. It's basically made using the roller template, no custom logic added. It isn't a basic scene, though, but it doesn't have any custom asset or logic on it, since it's directly created from UE project wizard. Tried launching using DX9,10,11, since UE doesn't go with 12 by default. I'm having issues uploading it (do we have a size limit here? Zipped file from UE is around 650MB, don't know why), so if you could create the project on your side to test this, I'd be really grateful.Meanwhile, I'll try to upload the project elsewhere to send you the link. Also tried with a blank project from the wizard, which does create a basic scene with 3 props on it. Still crashing.

As for the logs... Most of the logs under Documents/GPA/Logs are blank, and the CrashReport files don't say that much. I'll attach the MonitorLog.txt and the last CrashReport txt if it's of any use to you. MonitorLog just says that it "failed to attach to process", though. I'm also attaching the Monitor About data.

Thanks in advance

Attachments: 

Hello Ryan.

This is my roller project. Nothing besides the stuff the wizard adds.

Thanks in advance.

https://drive.google.com/open?id=0B2hf1qkV0GFFT2xRMEJqRnJlamc

Hi Andres,

Thanks for the extra info and uploads - its helped out a lot!  

I did make my own version of the rollerball demo over here, I was asking for yours just so I was sure we were using the same bits.  Both demos (yours and mine) do look the same and I built them both using UE 4.15.1.

I do have a question for you while I am looking into this.  When you say "as soon as I link the executable to the GPA, it will crash the process" what exact steps are you taking?  

Thanks for your reply Ryan.

I apologize for not being that clear in the issue (english is not my native language :( ).

As for the exact steps I'm taking, they'd be these.

1. Package the game for Win x64 (my machine is a 64-bit PC)
2. Run GPA
3. Look for the executable through the GPA UI
4. Select the desired command (executable) and click on 'Run'
5. The game will load with the GPA Gizmo at upper left corner, as if it's frozen, but as soon as I see the image of my test scene, the process would crash, leaving me an UE crash windows that basically says it can't show me any log trace because the executable isn't set up for debugging (I'm packaging for development, by the way.
6. After I close the UE crash window, I'd get a Windows notification from GPA saying that it "failed to attach to process", hence I'm guessing it's crashing when trying to link with my build. GPA will still be running, for the record. Also, if I try to run my build without GPA, it will run without issues.

Hope I did better describing my issue :)

Another thing I could try would be to run the test projects GPA comes with. Just to discard it isn't anything related to my installation. Let me get back at you as soon as I get that test done.

Thanks in advance.

Hi Andres,

No problem with the non-native language.  I just want to be sure that I am doing what you are doing.  It sounds like on step 2 you are launching the Analyze Application portion of GPA.  Do you see the same behavior if you launch the Unreal project from the Windows Explorer while also enabling auto-inject from GPA?

And that is good that you can see the GPA HUD within the Unreal window - so we are injected.

I did just remember a behavior I have seen with Unreal after I read your steps 5 and 6.  I have seen the Unreal process not closing entirely, especially after I see that crash log, which cause further Unreal launch attempts to look like what you are describing.  I would suggest to check your running processes in TaskManager to see if their are any zombie Unreal processes still open.

Good idea, try to inject into the gpasample workload that gets installed to your install directory (Program Files/IntelSWTools/GPA/).  I haven't been able to repro your issue, but I have some more ideas to try.

Another couple of suggestions I have to help narrow this down would be:

1) Update the gfx drivers for both your cards - ATI and intel

2) Disable the ATI card and restart - which would force your machine to use the Intel card (to try and rule out if one or both cards are causing this issue.

Hello Ryan. Sorry for the delay.

Did your suggested course of actions, and confirmed with my idea. It's the GPA linking with the application while my Radeon card is enabled. Disabling it and letting my PC running with the integrated Intel card doesn't crash the application. Also, used the City Racer demo (which lets me change the graphics device) and it will automatically crash when I choose to run it using my Radeon. Also I can confirm that using a Windows-based PC I don't get the API error I do with a Bootcamp'ed Windows and I'm able to use the frame analyzer. Just a last question... Do you have any notice on this issue happening with Nvidia cards?

Thank you very much for your assistance and patience, and sorry for the inconveniences.

Hi Andres,

No inconvenience at all!  I am happy to hear what you have confirmed and that it sounds like you are able to use your workflow using your Intel gfx.  I have not heard of a Radeon card causing this issue, but now I have something to look into on my end :)  Thanks for bringing up the issue.

Also, in case it wasn't a typo - I have not heard of this issue happening with Nvidia cards either.

Glad to read that, Ryan.

I've read again the about file I posted some days ago. When listing my Radeon card, it says it doesn't have support for GPA instrumentation, so maybe it's related. It could be related to that card being from a mobile line, since my Windows-based PC is a (middle-tier?) laptop. Hope that helps you pinpoint the issue.

Hi Andres,

That info does help pinpoint the issue - thanks for your help on this and for the testing on your side.

Leave a Comment

Please sign in to add a comment. Not a member? Join today