Applications closing instantly when using application anylizer

Applications closing instantly when using application anylizer

Iv been trying to get GPA to run with a number of different games (which have all worked in the past) but now when ever I try to run A game with GPA it starts and then instantly closes. At first I thought it was the game (since it recently updated) but then I tried it on some other games which, as I mentioned before, have all worked with GPA before, including this one. But now everything I try to hook it onto always, the program starts and then closes instantly. Iv uninstalled and reinstalled 3 times but with no luck. Anyone have any ideas about how to fix this?

Thread Topic: 

Bug Report
8 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi James, 

I'm sorry you're currently running into problems trying to analyze your project. I'm going to need you to provide a couple of additional pieces of information in order to help me frame the problem and better understand what could be causing it. 

Are you able to inject into City Racer (one of the samples that comes with GPA)?

If you're using Windows* as the host/target could you send me the About Info? This is done by running Graphics Monitor then right clicking on it in the system tray, then selecting "About". You can either send a screenshot of the about or write it out.

Thanks for the reply

GPA seems to run fine with City Racer, I tested everything else again to see if there was A difference but unfortunately not.

Here is the data from the about section

Machine name: DESKTOP-1USISUG
Windows 10 build 14393, 64-bit DEP enabled
Num Processors: 8
Memory: 8090MB
System BIOS: American Megatrends Inc. GL552VW.218 (03/16/2016)
Driver 0:
     Device: NVIDIA GeForce GTX 960M
     Provider: NVIDIA
     Date: 8-1-2016
     VendorId: 10de
     ProductId: 139b
     Stepping: a2
     No support for GPA Instrumentation
Driver 1:
     Device: Intel(R) HD Graphics 530
     Provider: Intel Corporation
     Date: 11-11-2016
     VendorId: 8086
     ProductId: 191b
     Stepping: 6
     Supports GPA Instrumentation
Install directory: D:\Program Files\IntelSWTools\GPA\
Version: 17.1.308306
Current user is in Administrators group: YES
Current Graphics Performance Analyzers 2017 R1 (17.1.308306)
Secure Boot/Trusted Boot is Disabled

Hi James,

Thank you for providing that information. Are you currently analyzing the applications with global injection turned on? If you haven't tried that, give it a shot and see if there is any change.

Do you know which card you are currently defaulting to? I'm assuming it's the integrated Intel® Graphics. If that's the case I would also suggest checking your drivers/updating them if you haven't already done so ><

I always run GPA with global injection on (as it usually won't hook without it)

I'm pretty sure I am using the Intel card. Iv updated my drivers but unfortunately still no results (although those driver updates were only for the wireless bluetooth and the proset wireless software).

In our team all developers that use Lenovo laptops with integrated Intel GPU have same issue.

Our game (.NET over SharpDX) crashes on creating DirectX graphics device if GPA monitor is running.

Lenovo have custom (vendor) drivers and i believe issue is somewhere there :(

If anyone from GPA team is interested - i'd be happy to provide all the info.


Could you send me a private message with your workload? So I can try to replicate your issue and see if I can find a solution. At the same time, could you update to the latest Windows* version?


Can you provide me with the "About" information for the machines that are doing this (just one "About" should be fine if they are all similar or the same build)? The "About" can be found by right clicking on the Graphics Monitor icon in the system tray. 

Sorry, how do I send a private message? and what is it you mean by workload?

As for Windows, I think it was the newest version that caused it to stop working, as A number of other programs where having issues and/or stopped working, which is why I went back. But I will do so if it will help.

Leave a Comment

Please sign in to add a comment. Not a member? Join today