Can't run on OSX, application closes unexpectedly.

Can't run on OSX, application closes unexpectedly.

I can't run my application from Graphics Frame Analyzer (or any other from the performance tools). Application closes immediately and the follow error is visible. Running application from command line works perfect. How do I get my application to run on graphics frame analyzer?

Here is machine info:

OS:
Name: macOS 10.10.5 (build 14F27) 
Locale: en_AR

CPU:
Architecture: x64
Cores count: 4

GPU:
Name: Intel HD Graphics 5000
Vendor id: 0x8086
Product id: 0xA26
Stepping: 9

Machine: Andrea’s Mac mini
Memory: 4096 MB
Screen: 1920x1080, 24 bit

GPA: 
Version: 17.3.314655

This error appears as application immediately closes after running it.

9 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hey Juan,

First of all, thank you for using our tool! I'm sorry you are currently experiencing issues with the tool, but I will get you back on track.

Have you tried launching the game using the Graphics Monitor, not Frame Analyzer? Do you see the same results in the scenario? Is the application you're profiling an OpenGL or Metal Application.

Hi Giselle, thanks for your answer.

I tried launching from Graphics Monitor, but the result is the same. Application closes two or three seconds after it opens. I am working with OpenGL.

If launched standalone, application works fine.

 

 

Hey Juan,

I just looked at your OS version, and we unfortunately don't support anything below macOS* 10.12. This is most likely the cause of your issue. To profile OpenGL* and Metal* APIs, you need to be running either macOS 10.12 or 10.13

Giselle, thanks again for your answer.
I upgraded to high sierra, but the problem persists.

Hey Juan,

What is the exact workload you are trying to profile?

Compiled Godot Engine from scratch on OSX:

https://github.com/godotengine/godot

Which generates a 64-bit executable: godot.osx.tools.64

I selected the executable and the path to one of the demos (executable reads a config file from working directory).

When running it, it immediately closes. Running the executable manually from command line works fine.

Juan,

I am going to try to reproduce this issue to determine the underlying issue. I will be in touch as soon as I am able to run Godot.

Alright , thanks a lot!

Leave a Comment

Please sign in to add a comment. Not a member? Join today