Crash of Analyze Application in pixel shader writing to UAVs

Crash of Analyze Application in pixel shader writing to UAVs

Hi,

I'd like to report a crash and get a possible fix.

I'm developing a DirectX11 renderer, where the pixel shader needs to write into UAV, in particular RWStructuredBuffer<float2x4>.
The Analyze Application tool helped me really a lot and it works very well for the performance debugging of my shaders.

However, since I started to use the UAVs in the Pixel shader (not Compute Shader, but I guess it doesn't matter), calling OMSetRenderTargetsAndUnorderedAccessViews function and Draw the scene with pixel shader causes a 100% reproducable crash during frame capturing.
If I remove the OMSetRenderTargetsAndUnorderedAccessViews call and then I call Draw to draw the scene with the pixel shader, the frame capture works perfectly, so I guess there must be a problem around the OMSetRenderTargetsAndUnorderedAccessViews call or around the UAVs writing in pixel shader.

I'm using MSI laptop Windows 10 x64
Intel i7-3610QM 2.3GHz
16,0GB RAM
Intel HD Graphics 4000

I tried to install the latest driver for this graphics card
Intel® Graphics Driver for Windows* [15.33]
Version: 15.33.45.4653 (Latest) Date: 5/23/2017

I tried to install the latest Performance Analyzer gpa_17.4_release_317348_x64_standalone, but the previous version had the same problem.

Thanks for your help!

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Cota,

Thank you for reporting this bug! I'll pass this on to our engineering team and see what the culprit is/how we could possibly fix the issue. 

Best,

Giselle

Hi,

If it helps anyhow, I'm sending you also a callstack from the crash.
I'm using a deferred renderer, then execute the commands with ExecuteCommandList call.
As you can see, the crash is not during the OMSetRenderTargetsAndUnorderedAccessViews  call, but during processing of the OMSetRenderTargetsAndUnorderedAccessViews command itself.
My program is running without any problems on different machines/graphics cards, so I guess it must be something wrong with the Analyzer.

Appreciate any help, thanks!

> KernelBase.dll!73fecbb2() Unknown

  [Frames below may be incorrect and/or missing, no symbols loaded for KernelBase.dll]

  d3d11_3SDKLayers.dll!ReportCorruption(unsigned int,enum D3D11_MESSAGE_ID,char const *,...) Unknown

  d3d11_3SDKLayers.dll!NDebug::CInterfaceSentinel::CFunctionSentinel::ReportMessageAndRaiseException(enum D3D11_MESSAGE_ID,char const *,...) Unknown

  d3d11_3SDKLayers.dll!NDebug::CContext::OMSetRenderTargetsAndUnorderedAccessViews(unsigned int,struct ID3D11RenderTargetView * const *,struct ID3D11DepthStencilView *,unsigned int,unsigned int,struct ID3D11UnorderedAccessView * const *,unsigned int const *) Unknown

  shimd3d32.dll!5040401a() Unknown

  shimd3d32.dll!50115c2d() Unknown

  shimd3d32.dll!5011c77a() Unknown

  shimd3d32.dll!500f760c() Unknown

  shimd3d32.dll!5040be65() Unknown

  CrystalEngine.dll!QueueRenderer::processQueue(void * p_args) Line 71 C++

  shimloader32.dll!52b43e62() Unknown

  kernel32.dll!767a8744() Unknown

  ntdll.dll!76ee582d() Unknown

  ntdll.dll!76ee57fd() Unknown

Hey Cota,

I have sent you a private message asking for additional details. If you could provide the additional details I've requested in that email, it would help tremendously in being able to log and pass on the issue to our engineering team.

Thank you!

Leave a Comment

Please sign in to add a comment. Not a member? Join today