Cannot set environment variables

Cannot set environment variables

I am trying to run the gpasample application, however, for some reason, the Graphics Monitor does not import any environment variable from my system. Even when I try to set up my own environment variables the gpasample subprocess does not have any environment variables in it.

The attached image shows what happens. Is this a bug? Am I missing something?

Thanks.

Thales Luis Rodrigues Sabino
6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Thales!

Oh no! This is due to the DirectX Runtime files being missing on your machine: https://www.microsoft.com/en-us/download/details.aspx?id=8109

Let me know if the issue continues after install the runtime.

Quote:

Giselle G. (Intel) wrote:

Hi Thales!

Oh no! This is due to the DirectX Runtime files being missing on your machine: https://www.microsoft.com/en-us/download/details.aspx?id=8109

Let me know if the issue continues after install the runtime.

I can confirm that is not the case. The DLL error I attached to the post is just an example of why the gsample application cannot be executed with the latest version of the GPA. If I double-click in the gsample.exe manually everything work as expected, the problem is when launching any application as a child process of the GPA. Again, as illustrated in the screenshot attached to the post, both the GPA and the child-process does not have any environment variables, so the only explanation is that the GPA is somehow removing all the environment variables before launching the actual application.

Another thing to consider, I tried an older version of the GPA and it is working fine.

Thales Luis Rodrigues Sabino

Hi Thales, 

This means you have already downloaded and installed the DirectX Runtime? The reason I bring this up is that this is the exact error that shows when you run our sample through GPA with this build.

What environment variables have you attempted to set? Does this error happen without trying to set an environment variable as well?

When you ran GPA using an old build could you also take a frame capture or did you only run the application?

Quote:

Giselle G. (Intel) wrote:

Hi Thales, 

This means you have already downloaded and installed the DirectX Runtime? The reason I bring this up is that this is the exact error that shows when you run our sample through GPA with this build.

What environment variables have you attempted to set? Does this error happen without trying to set an environment variable as well?

When you ran GPA using an old build could you also take a frame capture or did you only run the application?

Yes, the DirectX runtime is installed. I can run gsample.exe manually.

As per screenshot, I tried to set a variable called FOO=BAR for testing purposes. The error also happens when I don't try to set environment variables.

Yes, using an old build I was able to perform a frame capture and inspect the frame details.

Thales Luis Rodrigues Sabino

Hi Thales,

Can you please try re-installing the DirectX Runtime that I linked before we try to debug further?

Leave a Comment

Please sign in to add a comment. Not a member? Join today