jquery ajax call

jquery ajax call

I am trying to run a simple jquery based app which send request to server by using ajax function and getting json-formated reply to access data. jquery ajax call does not work for me if I run it in cloud9 environment. It seems that process stuck somewhere – it does not return success or error. The sample is attached. 

Am I doingI something wrong or could it be some limitation of  tool? Or maybe I am using incompatible version of jquery library?

If it test it locally (run index.html in browser – it works).

Downloadapplication/zip ajax-test.zip164.36 KB
5 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

The page you preview with Cloud9 runs as secure page (https://), Chrome blocks any insecure content accessed from secure page, in your case the flickr API is insecure (http), you have to open Chrome in --allow-running-insecure-content mode to make this work.
Close Chrome, open from command line and your example should work:

chrome --allow-running-insecure-content

Thanks! it works if I follow your recommendation.

Appreciate your prompt response!

as another possible solution, i offer this:

i was running a remote call to jquery CDN using http:// and this was failing. I switched to using a CDN that devliered the code via https:// and it worked fine.

Hi, the permissions on chrome are very important for run a web app.

Leave a Comment

Please sign in to add a comment. Not a member? Join today