Update linux kernel breaks advisor 17 update 4

Update linux kernel breaks advisor 17 update 4

Hello,

We did an update of our RHEL kernel from (RHEL 6.8) kernel 2.6.32-642.6.2.el6.x86_64 to (RHEL 6.9) 2.6.32-696.3.2.el6.x86_64.

Using the last version of advisor update 4 

ewart@bbpviz2 ~]$ advixe-cl  --version
Intel(R) Advisor Command Line Tool
Copyright (C) 2009-2017 Intel Corporation. All rights reserved.
Intel(R) Advisor 2017 Update 4 (build 517067) Command Line Tool

 

We get the following error message on a hello word. 

[ewart@bbpviz036 learning_engine]$  advixe-cl -collect survey ./a.out 

Intel(R) Advisor Command Line Tool

Copyright (C) 2009-2017 Intel Corporation. All rights reserved.

advixe: Collection started. To stop the collection, either press CTRL-C or enter from another console window: advixe-cl -r /gpfs/bbp.cscs.ch/home/ewart/learning_engine/e000/hs001 -command stop.

advixe: Collection stopped.

advixe: Warning: The application returned a non-zero exit value.

advixe: Opening result 31 % Processing profile metrics and debug information   

advixe: Error: Error 0x4000002a (Database interface error) -- Cannot run data transformation `Add Fake Loop Data'.

advixe: Opening result 99 % done                                               

advixe: Opening result 100 % done                                              

advixe: Error: Data loading failed.

advixe: Error: Unknown error during finalization

 

 

Thread Topic: 

Bug Report
5 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Looks like you may be having a pin problem (we're seeing a lot of them right now). Can you run pin on an executable?

 

Hello,

Thank you for the help.

[ewart@bbpviz036 ~]$ pin -- ./a.out 

Bus error (core dumped)

 

a.out is a simple hello word

 

 

I'm having the same problem with a program that does some loop calculations.  

Same error using pin also:

$ pin -- ./a.out 

Bus error (core dumped)

 

I was having the problem with a larger C program.  I was able to run vtune with that program, but got this error running advisor 2017 update 2.

Hello Intel.   Is there a workaround or fix to this?

I'm seeing the same issue with the 2018 Advisor XE, 4.11.4-1.el7.elrepo.x86_64

Leave a Comment

Please sign in to add a comment. Not a member? Join today