problem running ArBB example in evaluation guide

problem running ArBB example in evaluation guide

I am doing ArBB exercise 5 in intelparallelstudio-evaluationguide-pbb.pdf. Using Visual Studio 2010; also have Parallel Studio 2011 installed. I have made the code changes described in this exercise and it builds fine (release, x64.) However, when I try to run, I get an error The application was unable to start correctly. No other information is provided about the error. I have checked that my Path environment variable contains the proper directories for the dlls of ArBB and TBB.

Suggestions for what to try next would be appreciated.

7 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Lori, I'm the author of that guide and will look into it as soon as possible. I will contact you for more information on your error. Thanks.

I am also having the same problem. Would like to know how can I fix that.

You must first go to the start menu -> Intel software development tools -> Intel Array Building Blocks Beta -> then click on the visual studio mode that you are seeking to use. Then from Visual Studio you need to open up the samples solution. NOTE: The samples do not just run out-of-the-box. You must copythe samples directory into yourown home directory, and then build and run. This is because normal users do not have write access to the installation directory.

I have done the step you have mentioned and also tried to copy the sample to my home directory. However, that does not even compile. I tried to give the library and link and try to fix the "file not found" problem, but it gives me a list of error: "unsolved external symbol"

I have not been able to clear up my problem. I did get a lot of good advice from Noah and his colleagues. Unfortunately, we were not able to clear it up. The ball is in my court to try 2 other things they identified: use Visual Studio 2008 for the projects; get one of my teammates to try ArBB on their machine (they all have Windows NT, while I have Windows 7; we don't think the OS is really the issue, just want to get another person to try.) I haven't done either of these things yet. Needed to set aside my activities with ArBB in order to work on other project tasks.

Best Reply

Hi Lori,Ifinallyget my example running.I am using window 7 and visual studio 2010. Not sure we have the same problem but try the following:1) If you are running the sample program under ArBB, do not move the folder to some where else since it has dependence with the upper folder files.2) close all your files and programs to start fresh.3) go to Start>All Programs>Intel SoftwaredevelopmentTools>Intel Array Building Block>IA32 or Intel64(depends on your machine)4) a shell will pop up and in the command line, type>devenv5) your visual studio should start at this point, open the project you want to run and see if this worksThe steps are basically set up the correct environment for ArBB to run. I successfully run mine by following this steps.

Leave a Comment

Please sign in to add a comment. Not a member? Join today