Sine2D Sample Fails

Sine2D Sample Fails

Hello all,

I'm currently running with the following settings:

Win7 x64
MS VS 2005 Pro
Array Visualizer 3.3 (av_dev_ia32)
UAC turned off

My problem can easily be reproduced (on my machine anyway) using the Samples\\\\MFC\\\\Sine2D program. The steps I take to create the problem are as follow:

1- Open up Solution
2- Prompted to Convert to VS 2005, which it successfully does
3- Compile and run the program fine. I'm able to use the slider, move the graph and everything works fine.
4- Make the slightest change to the IDD_SINE2D_DIALOG Dialog (for instance, move the Edit Control a little)
5- Recompile (get some unimportant warnings about the resource.h file not being a MS one - cause it's got some Intel header)
6- Run - Program Asserts (see attached image)

Now, I've tracked down that the cause of the problem resides in the Sine2D.rc file, under the section:

IDC_AVGRAPHCTL1, 0x376, 154, 0
.... (************ problem is here **************)

I've tracked it down by making a backup of the folder before the change and comparing the differences after the change. Of all the changes that the .rc file can potentially go through, it appears that only this section matters and is responsible for the assert. Restoring that section only, while keeping the other changes to the Sine2D.rc file, will get the program running again.

Now, it should be noted that if I create a new similar project from scratch, and Insert the same ActiveX object (AvGraph Control), I get the same sort of Assert.

Any inputs would be greatly appreciated.


Downloadimage/png ASSERT.png29.8 KB
6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Does the Array Viewer work normally? I.e. you can open files and view graphs.John

Hi John,

Yep... Array Viewer works fine. I was also able to get Viewer to work in Fortran Debugger, following the guidelines provided in other threads.

Now, I HAVE done multiple Installs/Uninstalls of 32 Bits & 64 Bits versions as I didn't know which version to install. My OS is 64 Bits and I started with the 64 Bits version but things didn't work too well, so I Uninstalled and Reinstalled the 32 Bits Version. Since I was still having issues, I browsed under the \\Array Visualizer Folder and found these 2 files "AvRegAll.exe" & "Regall.bat" under the \\Bin Subfolder. I ran these 2 files as well. Then, Uninstall the 32 Bits and went back to the 64 Bits version and ran the same 2 files again... See where I'm going with this... lots of trial and mostly errors.

So at this point, I'm not too sure my Fortran related registries are healthy.

I have another Win 7 64 Bits image on my computer, which I'm waiting to delete. I wanted to boot to that disk and start from scratch there. But before I do, I wonder if you can help me with these 2 questions:

1- Should I install the 32 bits or 64 Bits version? Note that I don't have the 64 Bits Fortran Compiler installed on that machine (just the 32 Bits).

2- Should I run the 2 files mentioned above ("AvRegAll.exe" & "Regall.bat") after the install?

Thanks for your help.

The OS 32bit vs 64bit-ness doesn't matter as much as whether you are trying to build 32bit or 64bit apps. Whichever it is, make sure the corresponding version of AV is registered. Visual Studio comes with an ActiveX control test container that lets you interactively drop in any registered control. You can verify that you can load AvGraphCtl in the test container.Most worrisome is this thread:, indicating that it may be necessary to rebuild the control to work with VS2005 (some strange MFC version incompatibility?). Has anyone else had success building this sample?John


I haven't read the specific issue in details but the 64bit and registration issue look familiar. May be my last post here ( will help.


I have experienced similar difficulties and was going to enter a thread on installing "pure 64" system with Windows 7 64, Intel F11 64 config, MSVisStudio 2008, and AViz 64 bit. I have been able to install these and get the samples such as Sine2D to work fine. I found that being very careful (Adrian Monk careful) helped.
1. Make sure you are admin for theAViz Install and all other "first time" runs(run as admin won't do)
2. After install, make sure you are running regall.bat from the 64 bit folder
3. Make sure your samples are from the right place, check after conversion that you are generating .exe files in the x64 debug folder
4. Sometimes I could not get the graphs to come up in AVis examples until I played with the explorer panel on the left.

My main problem has been getting all the settings and environmental variables right in a new solution/project. I'm having a hard time comparing what options are set and what are not, going side by side with a working project (like a sample program) and a new one (like ones I have submitted in this forum) and I still don't get a good link to AViz routines in the new projects. It shows on the link log html files, but I can't find the magic words inside the project dialogs.
I can kluge by tearing out the Sine2D.f90 source and pasting in my .f90 source and it will work. This hardly gives me much confidence in my skills (aside from numchuck skills and hacking skills)

Leave a Comment

Please sign in to add a comment. Not a member? Join today