Array viewer bug

Array viewer bug

The following cause the array viewer to crash.

1. open the attached xls file in array viewer.
2. click on the hypertext 'sheet1' in the right pane.
3. click on the sheet1 in the left pane
4. click on 'root' in the left pane
5. double click on the hypertext 'sheet1' in the right pane.

the error message is 'unhandled exception in arrayview.exe (avgrid.ocx)

16 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Any news on this?

I'm now waiting for the next release with the other bug fixed that I spotted. Can you post a message as soon as this happens, as I'm desperate for it!

Is it possible to justdownload the new contents of the /bin directory with all the required array visualisercomponents init? I could then give the fix a thorough work out.



Book1.xls opens as a void document in AV.
In Excel (97) I see 3 sheets. Sheet 1 has a 5 column table of 23 rows. Sheet 2 and 3 are void.

Jim Dempsey

When I open Book1.xls I get a 6x22 dataset "Sheet1" that appears to have the correct data. I tried various combinations of clicking on the tree and the right-pane view, but couldn't make it crash.

Phil, does the crash happen every time? Do you see the crash if you first save the file to xml or hdf5?

Is the fix you are looking for the Single-Point XYPlot issue? Have you tried out w_fc_c_9.0.025 kit yet? We don't really have a way of providing just the bin AV bin files. The good news is that now there's a subset package containing just the ia32 bits. See:

Jim, I haven't tried loading Excel files in AV with Excel '97. The Excel loader plugin isn't self contained, i.e. it's using some Excel components to load the data. So I could imagine there's a dependency on a more recent version of Office. As a work-around you can save the xls file to a text file and then load that into AV.


Loading as text file did not work. Looks like I would have to upgrade MS Office. The '97 versions have all I need so I think I will pass on experimenting with Book1.xls


The bug I require fixed before I can deploy my app is the one that crashes the system - the one you replicated where you told me of a registry value I could change to make it behave better. Is this fixed in the new download.

(I consider real bugs one that crash the software - others are just inconveniences)

Also, could you post the web address of the new download file, rather than just its name. As a non frequent visitor I have no idea where to find this file without a bit of rooting around.

On another note - I forgot my password for premier support - and in order to reset it I have to not only remember what answer I supplied to my clue question - but I also have to remember what the question was. This seems somewhat pointless. If I had the capacity to remember all that, I would probably remember my password as well. What am I supposed to do?

Managed to get logged into support and find the download. The onlybug fixesmentioned about the array visualiser was something to do with the tool bar buttons.

I don't really want to download a 100mb file until I know if what I'm after has been fixed. Could you please advise if this is the case.



I saved the book1.xls as both a xml and hd5 file. I shut down the viewer, loaded it up again and opened the xml file. The array viewer still crashes with the message

unhandled exception in arrayview.exe (AVGRID.OCX) ACCESS VIOLATION

The same thing also happened with the hd5 file. I guess you can thus rule excel out as the problem.

Could you post the hdf5 file that shows the crash? Then at least I can factor out any vagariesdue toMS Office.

I don't think it's possible to provide just a url to the download file (someone correct me if I'm wrong). You have to log on to Premier first. There have been a lot of complaints about the log on procedure and I think it's slowly getting better. At least now your password doesn't expire every 5 days.

I'll test out your bug on the latest update and report back. This was the VB form with4 AvGraph controls, correct? Did you ever get around to trying out my suggestion of modifying the project to set the Root property of each control to the same AvGroup instance?


Here is the file. Its double clicking that seems to cause the crash.

I got into premier support eventually, but meanwhile they reset my password and now I can't get back in because every password I enter it says doesn't conform. This is the most paranoid system I've ever seen!

I didn't get around to making the 4 controls into 1. Don't want to waste much more effort on this until the known bug is fixed.



Regarding your premier account: have you tried emailing I'm sure someone will be able to get you back on track.

I tried your VB project with the w_fc_c_0.025 kit and no crash! So go ahead and give it a try.

I was able to reproduce the avgrid.ocx access violation this time. It's actually the double-clicking that seems to be the issue, not the file contents. I can get the same crash with tall.h5 for example. I'm surprised no one else has reported this. I'll research the problemand hopefully get a fix in for the next kit. In the meantime, refrain from double-clicking and you should be ok.


I installed this version but doing so effected the licence. I can no longer load my vb forms with the controls on it as it says it cannot find the licence. I'm hoping to get a solution of how I proceed pretty quickly.


This bug reminds me of a bug I saw a while back whereby a File In Use (in this case File Not Found) occured that inhibited the open in a manner that was determined benign (in this case there is no file containing the html) Then some code later on attemptedtoread this file thinking it was opened. I believe the file was intended to be a memory mapped file. The symptom resulted in an attempt to read location 0x00000000 of the virtual memory of the application (Array Viewer in this case). And this page of the virtual address is reserved to trap errant addressing.

Jim Dempsey


It looks like this update is incorrectly looking for a Beta license rather than a permanent license. I've fixed the code for the license checking module. To get the new version, close VB and any Array Viewer apps you have running. Grab the attached zip file, unzip it, and copy the exe to the Array Visualizer bin directory. You may also need to run: "avflexlm /RegServer". If you run Array Viewer now, the About Box should say "Array Visualizer Developer" and you should be able to drop AV controls into a VB form.


Is the bug you are talking about an AV bug? Is there a way I can reproduce it?

BTW, I have a fix for the double-clicking bug. I'll get it into the next update.


The licence fix worked ok.
Where do I send my invoice for finding all your bugs ;-)

I'm glad the license fix worked!

Regarding the invoice, I'll be happy to split all the extra money I get for being a forum host with you. :)


Leave a Comment

Please sign in to add a comment. Not a member? Join today