Array viewer hangs my machine

Array viewer hangs my machine

Strangest thing. I was running my program all this morning and everything was fine. All of a sudden, when calling favSetArray, my machine hung. When debugging, I found that it was at the call to favSetArray. To further complicate things, when trying to view the array just prior to the call using the Array Viewer capabilities in the debugger, I got the following:

1. An hourglass for a long time
2. a dialog box with a title of "Server Busy" and the following message

"This action cannot be completed because the other program is busy. Choose 'Switch To' to activate the busy program and correct the problem.

The possible buttons to click are "Switch To...", "Retry", and "Cancel", but the Cance button is grayed out.

When clicking on "Switch To...", the "Start" menu on Win2000 pops up, and then the Server Busy doalog box comes up again.

I end up in an endless loop between the two. I have to shut down the program from Task Manager along with a number of instances of the array viewer. I have tried rebooting, but this doesn't help.

I tried this on another machine and everything works hunky dory.

Any suggestions as to what might be going on?

13 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

This has been discussed earlier here and here, although with not much clarification.


I have this same problem on 3 XP machines. I support a pool of laptops and have been watching the forum for some time. I can't even view the sample files that came with the code.

We've had a handful of complaints like these, but have never been able to pin it down. Some users have reported that an uninstal and reinstall of Array Visualizer helps. Also, some video drivers aren't good at handling OpenGL, we've found.


Retired 12/31/2016

You can check the video drivers by running the Array Viewer application (Start|Compaq Array Visualizer|Array Viewer), opening a data file (e.g. storm.agl), and checking that it displays normally. If there's a problem, you can try starting Array Viewer and open the Options dialog (Settings|Option on the Array Viewer menu). There's a checkbox labeled "HW Acceleration". If it's checked uncheck it, or check it if it's unchecked. Exit the Viewer, restart and try opening the data file again. And of course, you may want to update and/or reinstall your video drivers.


I have updated my video drivers ...the viewer still hangs up. I installed the latest version of directx, with out any luck. However while playing with the "HW Acceleration" feature I was able to get an error when I clicked on the option to "restore Original" under default settings ...the error occurred in mfc42.dll. I believe I have the latest version of mfc42.dll. Any thoughts? Viewer does run well on a win 2000 machine.

That's interesting.

The "Restore Original" along "Save Current" buttons allows you to save or restore the default settings for various graph types (things like the graph style or background color). I'm guessing that some combination of default settings is causing the crash, but resetting to the "factory defaults" works ok.

It's odd that the crash occurred in mfc42.dll though. I would have expected the problem to be in either Avis2d.ocx (if it was a bug in Array Visualizer) or opengl32.dll (if it was a video driver problem that only occurs with specific graph settings).

Anyway, I'll add using "Restore Original" to my list of things to do when the viewer hangs. If you come across the specific action that causes the crash, let me know and I'll investigate further.


For anyones interest, starting Array Viewer and opening up storm.agl cured the problem. Everything now works fine when viewing an array.

It seems like this happened to me at least a year ago or probably more and I think this is what I did to fix it. Strange that bringing up the Array Viewer outside of CVF fixes a rather serious problem.

Rather than starting up another post, I will comment here on the forum behavior that a number of folks are having. It still sometimes takes an inordinately long time for the window to open when clicking on "reply". The process eventually times out.

However, when it looks like this is what is happening, a click on the stop button and then clicking on the reply button usually obtains a more rapid response. Sometimes I have to do this more than once. So, this problem does not appear to be related to the server going down. All other clicks when navigating the forum have a normal response.

I spoke too soon. Now I get the following error message (when just a few minutes ago the array viewer worked fine if a separate instance was also open).

The instruction at "0x019e4ec8" referenced memory at "0x00000004". The memory could not be "read".

Curiouser and curiouser.

Try this:

1- Run Array Viewer from Start/Program/Compaq Array Visualizer;

2- View some sample array and then in the menu bar select Settings/Options... and cilck on Save Current;

3- Try to view arrays when you are debugging your program from within Dev. Studio.


I solved the problem described before like this:
I went to "Video Properties", "Configuration" tab, "Advanced" button, and under one tab called something like "Problem Solution" * I changed the value of "Hardware Acceleration" to the lowest level. Since that Compaq Array viewer start to work fine, till yet.

* (i don't know exacly because my OS is in portuguese)

If the video driver has bugs, it can cause the Viewer not to display correctly or even (as in your case) crash the system.

I recall this situation was a lot more common when the Compaq Array Viewer was first released. Array Viewer uses the OpenGL api which wasn't very well supported. Things have gotten a lot better over time (I think mainly because the game "Quake" uses OpenGL) and I haven't seen this problem come up much recently. The control panel display applet will usually have a way to force software rendering which is more reliable (if slower).


If you have problems with OpenGL (you can test this with the OpenGL screensaver) you can reinstall OpenGL by installing the newest version of DirectX (from Microsoft). In this way, I could solve my starting problems with the Array Viewer.

Leave a Comment

Please sign in to add a comment. Not a member? Join today