vPro beginner question - Issue to use IDER boot to ISO

vPro beginner question - Issue to use IDER boot to ISO

My company is starting the implementation of vPro and so I'm taking a look at the c# API. So far I have managed to figure out most things but I have a problem to get the vPro client to boot to an ISO. My IDER code looks like this:


BootSource bootSource = new BootSource(BootSourceEnum.IDERCD);
     amt.BootControl.SetNextBoot(bootSource, BootOptionsFlags.UseSOL);
     Console.WriteLine("Boot option completed sucessfully");
catch (ManageabilityException ex)
     Console.WriteLine("Boot operation failed");
     Console.WriteLine("PowerReset success");
catch (ManageabilityException ex)
     Console.WriteLine("PowerReset failed");

It prints:
Boot option completed sucessfully
PowerReset success

It reset the computer successfully, boots into SOL mode but boot directly to hard drive. No error message anywhere. The iso works when I use powershell cmdlet invoke-amtforceboot.
Am I missing some step when I do this? I have tried to look at the examples and also in Remote Iso Launcher source code but cannot find anything else that I should do.


9 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

I will look more closely at this later, but could you let me know if you have enabled the Redirection Listener?Have you tried successfully doing an IDER session with the IMRSDK tool that is in the SDK or with the Developer Toolkit?  What version of AMT is your system and what version of the SDK are you using?

Thanks for taking a look.

According to the description of StartIDERCD() the listener should be enabled automatically when calling this method. Do I need to do something else to manually enable it as well?

I'm unsure of what you are refering to as IMRSDK tool, could you elabore a bit? I'm totaly new in this area so please bare with me.

AMT version is 7.1.3 and SDK is 8_4197.

Have you taken a look at this diagram in the SDK Docs?  (Make sure you are executing the correct flow.)  http://redfort-software.intel.com/sites/manageability/AMT_Implementation_and_Reference_Guide/DOCS/Implementation%20and%20Reference%20Guide/default.htm?turl=WordDocuments%2Ftypicaliderscenario.htmHere is some snippet code that you might find helpful to review:http://redfort-software.intel.com/sites/manageability/AMT_Implementation_and_Reference_Guide/DOCS/Implementation%20and%20Reference%20Guide/default.htm?turl=WordDocuments%2Fsampleusingthevpromodule.htmHere is information about the IMRSDK sample GUI:  http://redfort-software.intel.com/sites/manageability/AMT_Implementation_and_Reference_Guide/DOCS/Implementation%20and%20Reference%20Guide/default.htm?turl=WordDocuments%2Fredirectionsampleconsolegui.htmFor additional testing, you can run the AMT SDK supplied Redirection Sample GUI (link to information above) or you can run the DTK (Developer's Tool Kit) as well. These are good tools to rule out where the problem is or is not.If all this does not help,  could you run the SCSDiscovery Tool and attach the XML file so that I can get a better idea of how your system is configured?  Here is a blog that shows you how to run it:  How to run the SCS Discovery Tool


Sorry for the late reply, I had to be out of office for a few days.

Thanks for the detailed links. The flow in the first is based on c++ code if I'm not misstaken. Where in this flow would StartIDERCD be? IMR_Init and/or IMR_OpenTCPSession?

I can see functions called in the powershell example through a Intel.Management namespace but I cant find these in the c# API. The closest would be Intel.Managebility but I cant find any functions there to initialize the library like the powershell examples does.

When using the redirection sample IMRGUI.exe I just get an error: "Could not initalize IMR SDK". However the command line version AmtRedirection.exe seems to be working and using this tool I can open an IDER session and enter the path to my ISO. When I then do a IDER CD boot, it boots successfully to my ISO.

If I use the same code as seen above but change BootOptionsFlags to BiosSetup and remove StartIDERCD, the computer boots into Bios successfully. So it looks like IDER is working and I'm doing something wrong in telling the AMT device how to look for the ISO.

Are you on Windows or Linux?

It's all Windows, we actually have an appliction written in c# already to do certein client managebillity and hence I'm looking into using c# to integrate vPro directly into our existing application. So thats why I'm looking for c# specific info.

I attached the system discovery xml file for you as well.

Ok - thanks for the info.  I'm not seeing the discovery xml file..  Did you attach it?If you are looking for C# examples, the DTK is written in C# and you can download the source from our Community.

Hi again,

Managed to find an alternative way from the DTK which was to call an AmtRedirectorWrapper to start the redirection and then the IDER boot was successfull. I dont know if this is the best way to do it but at least it is now working.

Thanks for taking the time to answer all my questions.

Leave a Comment

Please sign in to add a comment. Not a member? Join today