Intel ME/AMT fails to be loaded or is corrupted

Intel ME/AMT fails to be loaded or is corrupted

Hai there,

im having a strange issue with ME FW

It sometimes fails to be loaded on boot and the bios is showing or and not the correct version, of course its inopperable then, too.

Im hoping someone can provide me the files for 4M Sku as i think a simple reflash could fix this but i wasnt able to locate the files i need for this operation as of yet.

Best regards

23 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

What system are you working with? (which OEM, what's the model, what processor does it have?)Need to make sure you have an AMT 6 capable processor. Also 6.0 is not the latest version of AMT 6. You should be able to get a 6.2 release from your OEM.Gael

well i am having the same problem.i have AMT 6 Capable processor and have version 6 of AMT .but it still fails to be what am i supposed to do??

I will need to know more about your systems: Please run the SCS Discovery tool and attach your XML file:

What tool are you using to update your firmware (does it require a password for the ME?) System is shut off? Network Cable is disconnected?You might also try resetting the CMOS (take the battery out for 20 seconds - when network and power is disconnected.) This is easy if it is a desktop system. If it is a notebook then there might be a bios option to "Disable AMT", save, reboot and then Enable AMT - on some OEM systems this will in effect clear the cmos. Then you can try to update the firmware again.

Hello Gael,

its a Pegatron Mainboard with HM55 and i5 540M, by the way I've 2 MB's where one is working like a charm and AMT is fine - so if you could be so kind a provide me a Tool to Dump v6 FW (FWUpdLcl -SAVE is on v7 versions and above) I think I'm fine again. I also tried fpt.exe -D but it gives me that:

Error 26: The host CPU does not have read access to the target flash area. To enable read access for this operation you must modify the descriptor settings to give host access to this region.

The next thing i tried was extracting the ME FW of the Bios IC itself (having a Galep here) and cutted it via WinHex on the appropiate points but theFWUpdLcl versions i found say its an invalid Header, although i can open it in fitcjust fine - suggestions?

Is the SCS Discovery tool available for Dos? Sys isn't running a Windows OS.

As last another question - is ME FW designed for each System or are they generic for the same Chipset Branches?

Best regards and thanks for looking into this!

Hi -There are some diagnostic utilities on the Intel Support site - this one looks at the chipset drivers, for example. windows OS's)Bios Self Test Utility (this one is OS independent): this tool might assist you in getting the right firmware - but I don't know. We used to be able to download the firmware from the Intel support site directly, but I couldn't find it (I am still looking.) It could be that it is too old.The SCS Discovery Tool works on Windows - not DOS, as does most of the other tools we have. Would it be possible for you to make a Windows boot disk and then you would be able to run the diagnostic utilities?Also, in order to use the ftp -D command, you have to have the flash descriptor override or dediprog type access. (I am also still looking into this question and will get back with you when I get an answer.)The only other option I would see is if you can get download support for BIOS and FW from your Mother Board vendor. As far as your question about FW compatibility, I usually look for downloads for a particular Board - there are not multiple versions for every combination of processor/board.In your Bios - make sure AMT is enabled. (I'm sure you have already done this.)

Hello - I just wanted to provide an update. The systems you have will have "locked" parts so you will not be able to extract the Firmware.So I have a few questions:Did you try clearing the CMOS?Can you get the FW from your Vendor's support site?Did you try the BIOS Self Test Utility?Gael

Hello Gael,

thanks for the feedback. I tried resetting cmos/the Self Test Utility - files attached for both working and non working Mainboards

The only issue with ME i can trigger out of them is the [16] ME UMA Size Valid, as its stating failed. Also i installed a windows os to run SCSDiscovery - i came across an issue which i didnt notice before, LAN Controller was missing so i think its locked down by me and therefore it also fails to be loaded completely as the ME cant load the Ethernet part either?! Anyways, here is the output just for completeness:

2010-12-03 10:15:54:(ERROR) :, Category: AMT Interface error: Failed while calling Soap call GetCoreVersion. Intel AMT connection error 0xc000521c: A TCP error occurred. Make sure that the destination settings are correct and that a network connection exists to the target. , error in discover 0xc000521c

So my question now is - is it possible to overwrite any existent security checks/passwords or is this done by flashing a higher/same ver of the ME, is so i'd still need the file!? Just to be sure I double checked the bios settings regarding set pw's and all are unset (It's an Ami Aptio Bios)

Last but not least, i can not receive the ME Firmware from the Mainboard Vendor as there is Zero support... neither i've found a 6.1 or 6.2 ME FW that was flashable on this specific SKU.

May i attach the extracted It can be loaded into the ftutil just fine as stated before (just not flashed with the tools i found of yet).

Oh and what do you mean by

/* Also, in order to use the ftp -D command, you have to have the flash descriptor override or dediprog type access. (I am also still looking into this question and will get back with you when I get an answer.)


dediprog is nothing else but an external spi programmer right? So just as the galep i used to extract the whole 4mb of the flash?

Best regards


Downloadapplication/octet-stream DUMP.ST158.67 KB
Downloadapplication/octet-stream DUMPNW.ST155.63 KB

Hai again,

i tracked the issue down to the NIC (Atheros AR8131), on PXE boot it has an correct Mac but the GUID is FF...., is Me Fw reading this and returns something like lan_load_fail and so fails to load completely?

I did another test and replaced the first 2MB's of the flash with v7 MeFW, bios is stating version and on boot a popup says Me Update failed, so im pretty sure having the correct v6 fw will fix my problem, so i kept reasearching the internet for a 2Mb sku update file but i sadly found none, probably because its too old (just like you said) so - doesn't intel have some kind of archive where such firmware remains?! Hopefully you can help me on this issue as its kinda driving me nuts after 2 weeks of testing...

Best regards

Hi - I escalated this to our FW engineers. They are asking for you to run the MEInfo tool and include the output to this thread. If you do not have this tool, let me know.
Regarding the Mac Address - there should not be identical Mac Addresses on your network so when you do flash with new fw, you do need to update the Mac Address with the correct address.

Hello Gael,

please find the log files for MEinfo as attachment. I ran the versions i found while researching, if you could give me the version apropiate to the amt version the mainboard uses i'll ofcourse run them.

In the meantime i fixed the NIC error, also i've a GUID again on PXE boot.

When looking at the MEinfo logs theres seems to be an error which I haven't noticed before - the Ignition Firmware(I suppose MeBX to be that) within the bios is failing and not the MEFw itself... Its the current version of the bios tho...

Best regards


Downloadtext/plain GAEL2.TXT1.19 KB
Downloadtext/plain GAEL1.TXT1.36 KB

Hi - one more question - where are you located? (we are wondering if you are by any Intel locations.)

Hai, mid germany describes it best. The closest Intel lab i know of is in Dresden (~300km from here).

Best regards

Hi - could you now run the MEINFO with the following command? MEINFO
fwstsThen send over the results again.Thanks!

Hello Gael,

here is the result of the invoked command.

Intel MEInfo Version:
Copyright(C) 2005 - 2009, Intel Corporation. All rights reserved.

FW Status Register: 0x00001055
FW Status Register1: 0x201A0000

CurrentState: Normal
ManufacturingMode: Enabled
FlashPartition: Valid
OperationalState: M0 with UMA
InitComplete: Initializing
BUPLoadState: Success
ErrorCode: Unknown Failure (1)
ModeOfOperation: Normal
Phase: Privilege Micro-Kernel

and this on a working one:

Intel MEInfo Version:
Copyright(C) 2005 - 2009, Intel Corporation. All rights reserved.

FW Status Register: 0x00000245
FW Status Register1: 0x69000000

CurrentState: Normal
ManufacturingMode: Disabled
FlashPartition: Valid
OperationalState: M0 with UMA
InitComplete: Complete
BUPLoadState: Success
ErrorCode: No Error
ModeOfOperation: Normal
Phase: HOSTCOMM Module

Best regards


any news on this subject?

Best regards

Checking - sorry about the wait.

Any update on this? I have an ASUS G75VX and I'm outlining the complete how to and tutorial on how to Unlock the System BIOS as well as Overclock the GPU. Here is my forum link: I also get the Error 26 when trying to dump the FULL 8MB BIOS including the ME portion and I'm trying to figure it out. I don't want to buy an EEPROM SPI JTAG yet. One of the people helping out in my topic suggested disabling Secure Boot, I'll check that now for me.

It's unclear what you are requesting. This forum is about using ME for Intel vPro/AMT, not about overclocking or BIOS.

I'm trying to dumb my FULL BIOS, which on my laptop is 8 MB, this includes the ME portion, which will allow me to unlock the timings and overclock my CPU. I'm using FPT to dumb my BIOS, I do this from a DOS USB drive not within windows. When I use FPT, I get the same error as you: Error 26: The host CPU does not have read access to the target flash area. To enable read access for this operation you must modify the descriptor settings to give host access to this region. I need to find out how to fix this error so that I can dump my FULL system BIOS and get more overclocking abilities. Everything is connected. We are using the same tools, we have the same error. Doesn't matter what our project is, just that we are in the same boat in terms of our road block.

You need to check with your motherboard manufacturer. They are the only BIOS supplier for your motherboard.

ASUS won't know anything, the tool I'm using is Intel Flash Programming Tool (FPT). When I run it, I get Error 23. How do I fix this error? I have an Intel Core i7-3630QM. Is there a program I can run, or something I need to enable in my BIOS? For my BIOS, I can dump it and modify it with AMIBCP so if the setting you tell me isn't available, I can just unlock that option in my BIOS then enable it. I read somewhere online that I might have to remove a portion of my BIOS? Is this true? Or I should be able to have full control over the settings once I enable something?

This is Intel's help forums, they know more than any one about the program I am using and the cause of Error 26, as well as what is required before I can dump the ME (Intel Management Engine Interface) portion of my BIOS. Also, my BIOS chip is one that Intel manufactures, so I'm still in the right place. MX25L6405D is my BIOS chip.

This forum is for the support of Intel business client software development, notably AMT / vPro technology. It does not provide any support for modifying or working with the BIOS beyond the MEBx menu options and the usage you're describing does not fall within it's realm.  Perhaps you could check with where you  got the tools. 

Leave a Comment

Please sign in to add a comment. Not a member? Join today