Can't setup KVM via kvm.hta

Can't setup KVM via kvm.hta

Hi there,

I tried to setup KVM remotely via the Out-of-box KVM Remote configuration.
I opened kvm.hta as an administrator and executed Step 1: Configure WinRM, which executed without any problem.
In Step 2, I entered the IP address, the admin password and the new RFB password and clicked on "Enable".
The resulting output was "WSManFault: Access Denied".
I'm not sure whether the other data is correct: I entered "admin" as Admin User Name in the Adavanced Settings. But I can't figure out where this name is set or can be changed.
As "Admin Password", I entered the password I changed in the ATM BIOS setup. I think this is correct.

So what can I do to get KVM up and running via kvm.hta? Are there other possibilities to configure KVM?
If you need any other data I can provide to solve the problem, please ask.

Thank you for your effort!


Fabian Pachner

6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi - I'm sorry that you are having difficulties. Just so that I can get a quick idea of what system you are working with and whether or not it is provisioned, could you please run the SCS Discovery tool on your AMT Client and include the xml file in your next response? I'm including a link that will show you where to get the tool and then how to run it.How to run the SCS Discovery ToolThe Admim password would be the password you changed it to in the MEBX menus and the new RFB Password is specifically for the KVM operations. It must be exactly 8 characters long.Are you running the KVM tool with administrator priviledges? WINRM does require this.

Follow me on Twitter: @GaelHof


Thank you for your answer!
I ran the SCS Discovery Tool and the output seemed just fine.
I have attached the file so you can see the system properties.
I have also checked that there is an Intel Integrated graphics card installed.

I have run the kvm.hta tool with administrator privileges.
Is the "Admin User Name" field important? What is the correct value for this field?

Thank you for your help!




Downloadapplication/xml OutputScsDiscovery.xml4.27 KB

Thank you for sending me the file. It looks like everything should be fine. And you said that you checked for your system having integrated graphics so that's good too.Admin user name should be "admin" - you use this to log into AMT - can you verify that you can connect to your AMT system's webui from another system on your network? Go to http://:16992 and then use the "admin" user name and your ME password. Is your system on a corportate network? Sometimes our corportate networks block certain ports.The only other thing I can think of is that Winrm isn't configured correctly - you can look at this blog. I see that the tool that you are using allows you to configure winrm but I'm not sure it is actually doing it correctly - if you can send any other screen shots or error logs, that would be great.You can also download the Open DTK and try connecting to your AMT Client and setting up KVM from there to see if that tool works better.

Follow me on Twitter: @GaelHof

Thank you very much for your help!

The solution was kind of embarrassing: When I entered the password in the Intel ME setup, the keyboard layout changed to an English keyboard layout.
When I entered the password on a remote computer, the keyboard layout was different (German). So I had to determine which key corresponded to the key I typed in the different layout on the vPro machine. Then everything went fine and I could configure KVM.

Of course, this is a silly mistake, but I think other users might run into the same problem as the password must have at least one special character.
So this should be documented somehow.

Thanks for your help!

Kind regards,

I am so glad you figured that one out! We have actually had a couple instances where it was the keyboard causing the problem. But I wasn't thinking that this was a keyboard issue.

Follow me on Twitter: @GaelHof

Leave a Comment

Please sign in to add a comment. Not a member? Join today