Outpost Tool not connecting localy

Outpost Tool not connecting localy

Hi. I have a Aopen media player DE67-HA with latest bios 1.01
AMT is provisioned and I can manage the pc remotely. Even KVM, console and redirection works.

The problem I have is with enabling Outpost on this managed pc. I am using latest "Manageability_Developer_Tool_Kit_7_0_11340_2". I imported certificate to Outpost. But still error prevents me to connect.

Below is screenshoot of error and ME information. What am I missing here?

13 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Would you mind downloading the SCS Discovery Tool, running it on your Intel AMT Client and attaching the xml file to this thread?Here are some instructions if you have difficulty finding it or running it. I'm just not familiar with what this is:Aopen media player DE67-HA - doesn't sound like it would be an Intel AMT /Intel vPro platform so I just want to see what the discovery tool says. Once we know for sure what we are working with we can do a bette job helping you.You are running the Outpost tool directly on your Intel AMT client, correct (assuming your system is indeed capable of running Intel AMT..)

Yes of course. Here it is attached.

And yes this is AMT platform. Dont mind the platform name :).

Yes I am trying to sucessfully run Outpost tool on local AMT client.


Downloadapplication/xml DEMO-PC.WORKGROUP.xml3.99 KB

Thank You for sending the XML file - it's very helpful. I just have a fe questions.It shouldn't need a certificate - your are running in Admin Control Mode without TLS.Another thing to look at is the password - do you have other AMT admin users defined? If you do, you may need to be using the ME password and not your AMT admin password. (Actually it looks like it wants an admin password so this should be OK too.)Can you verify in your Services that your LMS service is actually started? In order to do AMT things locally on the client, you do need the LMS service to be running. I see that you have the software installed, so that's good.The only other thing I can think of, is perhaps there is a bug in the DTK. Could you try the Open Source DTK and see if you still have issues?

Yes I know it should not need certificate. Funny thing is that AMT is configured in Enterprise mode. I tried to find SMB mode but can't find it in bios.

Anyway I don't have any extra users setup in AMT. Only admin and I use one and only password. So that couln't be the source of problem.

Yes LMS service is up and running automaticaly.

I donwloaded Open source DTK and now I can manually connect Outpost tool.
But when I try to setup Outpost service with "managebility Outpost tool - configuration and control" tool then I get an error. I attached the error message...

So there is progress but not completelz there yet :).


Downloadtext/plain error.txt5.1 KB

Ok - the error file doesn't seem to list any errors - was there another file?Regarding Enterprise vs. SMB. AMT 7+ has different modes - Admin Control Mode and Client Control Mode. You can read more about the differences in the SDK (just do a search).If you do a Host Based Provisioning directly on the Client, it will be in Client Control Mode. If you configure via the MEBx Menus, it gets put into Admin Control Mode. There are some capabilities that are not available in Client Control Mode and I beleive user consent for KVM sessions is required. I would say that ACM is more like Enterprise Mode (your system has been configured in ACM.)Since I can't think of anything else that might be blocking your sucess, I will escalate this to the appropriate developers.You are running everything with Administrative priviledges, correct?Thank You for your patience.

Here are some more things to try: (I did finally see the error - it was right up on top of the file....)

Browse to localhost:16992 or 16993 and make sure something happens. You should connect to 16992 since you do not have TLS implemented.

If in Mutual-auth
mode, Outpost will need a client certificate to log in. (This should not be applicable to you.)

Check the
username/password. The user account needs to have local access rights. If
remote only, it will not work.

Are you using your ip address to connect, or are you typing in a host name? If you are trying with the host name, you might want to try it with the actual IP address as well. Have you input a host name for the ME? Just posing questions - I'm not actually sure if you have to do so or if you haven't and you try to connect to the ME using your host name that that is part of the OS configuration, if it would be able to resolve it.(I did finally see the error - it was right up on top of the file....)System.InvalidOperationException: Cannot start service Manageability Outpost Tool Agent Service on computer '.'. ---> System.ComponentModel.Win32Exception: The system cannot find the file specified --- End of inner exception stack trace ---System.InvalidOperationException: Cannot start service Manageability Outpost Tool Agent Service on computer '.'. ---> System.ComponentModel.Win32Exception: The system cannot find the file specified --- End of inner exception stack trace ---

Hi. I managed to switch over to Client control mode as I dont need ACM. Remotely I can still control this managed pc and all works ok.
But localy on managed pc this Outpost service still does not work.

Yes I am using IP to connect, never host name. Yes I am trying all this with windows administrative priviliges. I am not using certificate with Outpost anymore.

I tried localhost:16992 on managed pc but it does not open anything.

How do I setup AMT user account and check if it has local access rights? And honestlly what does it have to do with not being able to run Outpost as a service level where no AMT priviledges are being asked for?

I am getting out of ideas on this one. Outpost service wors for me fine on some old AMT 4 machine, but here on AMT 7 it's a nightmare...

I'm sorry that you are experiencing such issues. You said that you switched back over to CCM? When did you do that? I was recently told that outpost only works in Admin Control Mode? Were you trying it in Admin Control Mode and it still wasn't working?

I switched to CCM just before I posted my last reply here. Outpost was not working in ACM and it is not working in CCM either.


I just got a new DE67-HA (specifically because of AMT), and have ran into an odd issue (contrary to configuration instructions). AMT seems properly enabled in BIOS, yet when I enter the ME BIOS EXTENSION (via Ctrl P), I am not asked for a password, I don't any references to changing/setting passwords, and I don't see how to proceed beyond that point.

Please assist. Thank you.

Hello - could you please run the SCS Discovery tool on your system and include the resulting XML file in your next response? Instructions on where to get the tool and how to run it are here: How to run the SCS Discovery ToolThis will let us know if you have a system that is Intel AMT Capable.

What is the version of your FW? And what version of AMT is this system? Also, what processor does it have?

Leave a Comment

Please sign in to add a comment. Not a member? Join today