Can't read ME_System property. No ME_System instance.

Can't read ME_System property. No ME_System instance.

When I run AMT_SDK\\Window\\Intel_AMT\\Samples\\WMI\\SystemProperties.vbs, I get the following error on line 59:

(null): 0x80041004

Looking at the code, my guess is that the query is returning no instances. Here's the query:

Set objWMIService = GetObject("winmgmts:\\\\" & strComputer & "\\root\\Intel_ME")
Set colItems = objWMIService.ExecQuery("SELECT * FROM ME_System", "WQL")

Also, I know the methods for ME_System are static. I can successfully call ME_System.getCapabilities().

Now I'm trying to read ME_System.FWVersion, which is a property. I can't find a static method that provides the FWVersion.

Do I need an ME_System instance to get the FWVersion?

If so, how do I create an ME_System instance?

10 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi dlonra,

Have you taken a look at the sample code in the SDK? This is a snippet from the SystemProperties.vbssample. Does this help?


' Connect to Intel_ME namespace
Set objWMIService = GetObject("winmgmts:\" & strComputer & "\root\Intel_ME")

' Get ME_System object collection
Set colItems = objWMIService.ExecQuery("SELECT * FROM ME_System", "WQL")

' For each object in colItems collection print some of its properties
For Each objItem In colItems
WScript.Echo "Capabilities: " & objItem.Capabilities
WScript.Echo "CryptoFuseEnabled: " & objItem.CryptoFuseEnabled
WScript.Echo "ElementName: " & objItem.ElementName
WScript.Echo "FWVersion: " & objItem.FWVersion
WScript.Echo "ManageabilityMode: " & objItem.ManageabilityMode
WScript.Echo "Name: " & objItem.Name
WScript.Echo "PlatformType: " & objItem.PlatformType
WScript.Echo "UserSegmentType: " & objItem.UserSegmentType

Follow me on Twitter: @GaelHof

Thanks, Gael

The query is returning NULL:

x = objWMIService.ExecQuery("SELECT * FROM ME_System", "WQL")

So, I guess I don't have any instances of ME_System. Yet, I can call ME_System.getCapabilities() because all the methods of ME_System are static (according to SDK documentation) and I don't need an instance to call methods. However, it appears that I _do_ need an instance to access the properties.

Do I need to create an instance of ME_System?

Are you able to run the SystemProperties.vbs sample that is in the AMT SDK without getting that error? You are running it on the local AMT Client, right?

Follow me on Twitter: @GaelHof

When I run AMT_SDK\...\SystemProperties.vbs, I get the following error message:

...\SystemProperties.vbs(59,1) (null): 0x80041004

I am running it locally.

Are you running this as "Admin?" You should be getting the UAC prompt to OK this command. (You can't run this by double clicking on the script.)

Yes you do need an instance (you have one through the enumeration.)

If you are running as admin and you still have the issue, could you tell us what version of AMT &FWyou are testing this on?

Follow me on Twitter: @GaelHof


I ran SCS Discovery and found that the two systems I'm testing don't support AMT. I ordered a Dell vPro system last week... waiting...

Is there a better way to get the AMT and FW versions?

In the meantime, the XML file produced by SCS Discovery includes a value. Is that the same value represented by the FWVersion property of the ME_System object?

Thanks again for all your help.

Well, this explains things. :-)

If you have the system that has the OEM AMT software installed (heci drivers, lms,..) you would probably have the IMSS software installed. You can just bring that up and it will tell you. Otherwise, I can't think of any other tool that will tell you the fw/amt versions.

And yes, the FWVersion would be the same as reported in the SCS Discovery tool.

Take a look at this blog - it shows output from various tools that you can run in order to look at AMT and FW versions: Communication error between application and Intel ME module (FW Update Client)

Follow me on Twitter: @GaelHof

When I get my vPro system I expect I'll have better results :)

Thanks again for all your help!

Me too. :-) I'll go ahead and close this "issue" within our system.

Follow me on Twitter: @GaelHof

Leave a Comment

Please sign in to add a comment. Not a member? Join today