WMI: Provider not found

WMI: Provider not found

Hi! I'm using WMI CIM Studio to navigate the ME_System class. I can see the class and its properties and methods, but when I try to execute "getCapabilities" I get an error message that says "WMI: Provider not found".

I think I need meprov.dll, but I can't find it anywhere. Has anyone encountered this before?

Thanks!

19 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hello dlonra,

The WMI interface is implemented using the Intel ME WMI provider (MeProv.DLL) included by OEMs in Intel vPro installations. The provider abstracts lower level commands to a set of classes that support discovery and configuration. This capability is part of Intel AMT Release 6.0.

Can you give us a little more detail on your vPro system? What release of the FW or AMT is it running? What OS is on your system? You should check out this blog about makingsure you have winrm installed and that it is configured correctly.

Follow me on Twitter: @GaelHof
Facebook: https://www.facebook.com/GaelHof

Thanks, Gael.

I'm experimenting with vPro and AMT on a built-from-scratch PC. The only OEM software I have is the ASUS motherboard drivers. Is there any other way to get the MeProv.DLL?

I've installed the following:
Intel_AMT_Release_7.0_SP1_SDK
IntelvProModule-3.0

My test machine is running 64-bit Windows 7 (on a 2nd Generation core i3)

I would like to run the "getCapabilities" method locally on my test machine.

Hi dionra,

Unfortunately, the Intel Corei3 processors do not support Intel Active Management Technology. Intel AMT requires processors that have a Manageability Engine (core i5/i7). I wrote a -->blog <-- a while back letting people know what to look for when purchasing AMT capable systems.

Another good resource to use if you are building your own system is at this -->URL<-- . Select a processor and you can easily see what features/technologies it supports.

Follow me on Twitter: @GaelHof
Facebook: https://www.facebook.com/GaelHof

Gael,

Is the ME Provider just a means of communicating with the MEI? If so, shouldn't I be able to make WMI/ME queries on any system with an MEI, even if it doesn't support AMT?

Thanks!

I knew you were going to ask that as soon as I hit "Submit."

The Intel WMI Provider makes calls to the ME so you have to have an AMT capable system to use it. WS MAN has generic APIs that can be used to make such queries to any system. As this Community's focus is vPro, all the tools we offer will be specific to managing a system using Intel Active Management Technology.

So the answer is "Yes" you can use WMI/WS-MAN to query the capabilities of your non-vPro system but not with our tools that will be communicating with the Manageability Engine.

Follow me on Twitter: @GaelHof
Facebook: https://www.facebook.com/GaelHof

Gael, I appreciate your patience.

I found another system for testing. This one has a vPro enabled processor (i5-2400S).

I installed the AMT 7.0 SDK
Next, I had to run mofcomp to get the ME provider MOFs installed from the AMT SDK (under DOCS/ME WMI Provider MOF). Should I have to do this?

Then, I used WMI CIM Studio to view the "root\Intel_ME" namespace and see "ME_System" listed under classes.
Finally, I right-click and attempt to execute the "getCapabilities" method and I get the same error about the WMI: Provider not found.

So, my guess is that I need MeProv.DLL, but I don't how to get it. What do you think?

Thanks!

>>...Intel ME WMI provider (MeProv.DLL) included by OEMs in Intel vPro installations...

Did you try to contact to Asus?

I also searched the Internet ( google.com ) and I found lots of linksfor MeProv.Dll. One of them is:

http://www.advancedpctweaker.com/dll-errors/MeProv.dll.html

Note: Please be careful if you decide to download.

You've tried with 'mofcomp.exe' application from '\Systems32\Wbem' folder, right?

Did you try to do any tests with 'wbemtest.exe'?

Best regards,
Sergey

Sergey, Thanks for your response.

It appears that the download link you provided only allows me to download a suspicious "MeProv.dll cleaner" so I decided not to do that.

The vPro enabled system I'm testing on right now is actually an iMac running Windows 7. However, I haven't tried contacting ASUS. I'll try that next.

Sincerely,
dlonra

ASUS says they don't have the vPro software, but that I can download MeProv.dll from Intel. Is that true? I haven't found a vPro download that includes that dll.

Hi - can you send me the actual model name/number for this ASUS system? According to ark.intel.com, the processor has the right stuff (although it isn't on my list, so I'm suspicious.) I would for you to try a few things on your system.

1. Run theSCS Discovery Tool and attach the outputxml fileto this thread.
After you have downloaded this tool, open a command window as "Administrator" and type in the following command:
>SCSDiscovery.exe /Output file test.xml SystemDiscovery /NoRegistry
test.xml will be a debug file - look for another file named with the FQDN of your computer - that's the one I want to see. It will tell us if your system is AMT capable and if it has all the right components.

2. Go into your Computer Management and look U-under the Services and Applications. You should see a "WMI Control" entry. If you right-click on that you can get the properties. Go into the Security Tab, expand "Root" and you should see "Intel_ME". If you see that, then the MEProv.dllwas included in your system build and itwill support the WMI Provider APIs.

And then you should be able to go to where the WMI samples are in the SDK: /Windows/Intel_AMT/Samples/WMI and type in the following:
> cscript SystemProperties.vbs from a CMD window

Does this command execute successfully?

Note that the WMI Provider dllis optional for OEMs to install or provide on their support site. If this is the case for you, you will not have the option of usingthe WMI provider classes and youraccess tothe MEI driver would be to use the API's documented in the AMT SDK (very limited set of APIs).

Follow me on Twitter: @GaelHof
Facebook: https://www.facebook.com/GaelHof

Gael, here's the information you requested:

(1) From the SCSDiscovery tool (the first few lines)
-
2011-12-03 09:13:36
false

WORKGROUP
TEL1207-PC
Apple Inc.
iMac12,1

All In One
C02FPC4JDHJF
Microsoft Windows 7 Ultimate
3945F636-051E-5651-A38B-E982EE296135
7.0.2.1164
7.0.2.1164
false
(The remaining tags were empty)

The "test" file that was generated contained, among other things, the following warning:

...Failed to get data from the MEI interface (Failed to connect to the Intel Management Engine Interface PTHI client...

I did confirm that my MEI driver (HECIx64) is installed and working properly.

(2) I did find Intel_ME under root in the WMIControl, but I suspect that is because of the "mofcomp" operations I did to add the ME mof files from the SDK to the WMI. (I kind of made a mess.)

(3) I attempted to run the "cscript SystemProperties.vbs" command and got the following:

C:\...\Windows\Intel_AMT\Samples\WMI>cscript SystemProperties.vbs
Microsoft Windows Script Host Version 5.8
Copyright (C) Microsoft Corporation. All rights reserved.

LMS service started: True
UNS service started: True
C:\...\Windows\Intel_AMT\Samples\WMI\SystemProperties.vbs(27, 1) SWbemServicesEx: Not found

I don't what this means.

Thanks again!

Yes, this is true and you can start at this LINK. You can search the download center for your motherboard/chipset, etc. You would be looking for the mei driver packages. I see that they are wrapped up in an exe. (ex for AMT7:MEI_AllOS_7.1.21.1134_PV.exe) This update works for the following desktop boards: Intel Desktop Board DX79SI Intel Desktop Board DX79TO
Again, you need to look for the update that works for your Desktop Board (I do not have that information here.)

Your Asus is an AMT 7 system, correct? So you will need to find the MEI driver package that has a 7.x versioning. If you run the exe it will expand the package and you will see a folder that is called "MEWMIProv." This is a last resort and we do not like to point our developers to the Intel specific tools because they have not been validated to run correctly on your OEM system (it doesn't mean they won't work, but it can mean that you may experience issues.)

Follow me on Twitter: @GaelHof
Facebook: https://www.facebook.com/GaelHof

Wait.. Is this an Apple? What is the system that is vPro Capable (The Asus?) Note that vPro is not supported on Core i3 and only only on PC's with Intel Core 5 and Intel Core 7. The blog that I referenced above identifies all the components that your systems needs to have in order to be capable of Intel AMT.

Your SCS Discovery output has the following line:
false

This means that even though the the processor is a valid processor, Apple does not supportvPro and therefore you cannot runIntel AMTon this system.

Follow me on Twitter: @GaelHof
Facebook: https://www.facebook.com/GaelHof

Sorry for the duplicate post.

I downloaded "MEI_allOS_7.1.21.1134_PV.exe" and installed it without any problems, but it doesn't appear to have the "MEWMIProv" folder you mentioned. (Could be operator error on my part.)

You've been very helpful. I'll keep looking...

I shall ask again... Are you trying to run this on an Apple?

Follow me on Twitter: @GaelHof
Facebook: https://www.facebook.com/GaelHof

Gael, I was originally trying to run it on an ASUS desktop with an i3 processor (no vPro capability).

Then, the only other system I could find with a processor that supported vPro was an iMac (so, yes I was trying to run it on an Apple) but the system had Win7 installed. The tests you had me run showed that AMT was disabled on this hardware.

Since this morning, I found a Dell Latitude E6520 with an i5-2430M that is vPro capable. Next, I downloaded an OEM file from Dell that contains the MEWMIProv folder you mentioned in an earlier post.

So, my next task is to install the provider and query the ME capabilities. This SHOULD fix the original problem, which was "WMI: Provider not found"

Thanks a bunch! You've been a huge help!

*Like! Now that you have the right hardware we can move forward. Let us know how it goes. So Dell does not include the MEProv.dll in their installation? (You did not see the Intel_ME namespace in the WMI Control under Computer Management/Services and apps?)

Follow me on Twitter: @GaelHof
Facebook: https://www.facebook.com/GaelHof

The guy who uses the Dell laptop re-imaged it, so I don't if it came with the Intel_ME namespace configured. I couldn't find any vPro stuff on the installation media, though. I'm planning to order another vPro-enable Dell so I can have a test environment that is fresh and untainted.

BTW: Once I installed the ME WMI Provider, my WMI queries worked as expected. So, a happy ending!

The download link that included the ME WMI Provider is this:
http://www.dell.com/support/drivers/us/en/555/DriverDetails/DriverFileFo...

Leave a Comment

Please sign in to add a comment. Not a member? Join today