AMT KVM Keyboard Mouse not working

AMT KVM Keyboard Mouse not working

Hi all,

Im testing the KVM feature from AMT on a Lenovo X201(3249-2EU).The KVM working fine
in bios mode and when im booting from a winxppe-cd. If i boot into the win7 pro
the keyboard and mouse not working. Ive tried it with the latest sdk and the latest
AMT-Driver from lenovo .Intel Management Version 6.2.10.1027 .
Have anybody any ideas about this issue?

thanks

14 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi steviewondering,
I have heard of a similar issue, but that was with a dell laptop and we sent the questioner to Dell as we didn't think it was an AMT issue. Hearing about this again makes me think this might not be a Manufacturer issue since you have already gotten the latest AMT Driver from lenovo.
Please help me to understand the complete issue. You can use the KVM from a remote machine to your Lenovo when you have an XP PE cd in the CD/DVD drive, but not when you boot into the Win 7pro desktop that is loaded on that Lenovo? Is that correct?

I'm going to look into this a little more. Look for an update shortly.

Cheers,
Judy

Hi Judy,

yes that ist correct. The KVM works too in the bios or in the preboot time of win 7.
I have changed and tried from different management boxes (XP/win7) and with
different VNCs (Ultra/Real).I have 3 new Lenovos all with the same problem.
I have many Lenovos running in our Company and this are the first with win7 and AMT.
The otherones running fine with AMT KVM and XP.

Hi steviewondering,
Ok, just wanted to make sure I had the issue correct. After discussing this with other engineers, I opened a request for support for you. This ticket has been assigned and I have asked that they communicate directly to you so you will get faster responses. I'm looking forward to hearing that they have been able to resolve your issue.

Cheers,
Judy

Hi Judy,
that sounds good.
Thank you

Hi steviewondering,
Just wanted to let you know that Pro Support sent me the following message yesterday:

"Still working on this one. I have been side tracked with another issue. I hope to have more data to provide later this week."

Pro Support doesn't seem to want to respond to you directly as requested, so I will relay any responses I get to you.

Cheers,
Judy

ok,
thank you for your support.
regards

Hello Steviewondering,

I am trying to reproduce your issue in our lab but I am not able to. I was wondering if you could send me the BIOS version information for your Lenovo X201 system.

My configuration is as follow:

System - Lenovo x201
BIOS - 1.31 (6QET61WW) I also tried v1.36 (6QET66WW) and v 1.37
Intel AMT Version - 6.1.10.1052 and v6.2.0.1027

DTK version - 7.0.11161.2

So far I have tested 3 KVM solution (ouside of the DTK) and they work as well. I think we just need to figure out what is different between my system and yours. Once we can figure that out, we can start working getting your system up and running.

Regards

Hi Larry,

my configuration is

System - Lenovo X201
Bios 1.37
Intel AMT Version - 6.2.10.1027
DTK version - 7.0.11161.2

Have you tried it with windows 7 ?
My KVM works in preboot phase and in bios config screen.
But after Windows boot only screen is ok and keyboard and mouse
isnt working.

Regards

I have been able to boot into Win Vista (32 &64) and Win 7 (32& 64)

Are you using a special kind of Keyboard and moues? Have you tried switching them out?

Also, are you connecting via the "KVM Viewer Redirection Port" or "KVM Viewer Standard Port"?

You may also try using TightVNC or UltraVNC. They are free to use and are similar to the RealVNC software that is used in the DTK. I believe the only difference is that they use a slightly different protocol to make the connections.

I will keep looking into this and see what else I can find out for you

Regards,

I have tested with different management boxes, win7 winxp different keyboards and mouse ( USB/PS2 ).
I used real,tight and ultra vnc on port 5900. Redirected Port is activated but I cant connect to it.
OptIN working but after this nothing happens.

Lets try booting the system into Safe mode and see if the mouse and keyboard work with your KVM solution. Since we know now it is not a DTK, RealVNC, UltraVNC or TightVNC issue we can start focusing on the client you are working on. I am suspecting that the issue is going to end up being a driver issue.

Also verify that all firewall settings are turned off.

Regards,
LM

Hi - I just looked up your specs and you should be fully supported for KVM. You might want to check out this blog and see if you are running into the same issue --> HERE <--

I am assuming you followed the guides in the SDK documentation? (Setting Up the Integrated
Viewer Application)
KVM is enabled in the BIOs? The password you entered is exactly 8 characters?
Could you run the SCSDiscovery tool on your system and send over the results? (I have documented the instruction on where to get it and how to run it --> HERE <--

Follow me on Twitter: @GaelHof
Facebook: https://www.facebook.com/GaelHof

I have a suggestion you may want to try. When doing KVM, Intel AMT will make it look to the OS as if you just plugging in a new keyboard and mouse device. For the mouse and keyboard to work, the OS needs to have loaded the drivers correcly and accepted to work with these two new devices. I suspect that something in your OS is blocking these drivers from loading or working.Start a KVM session and go in the device manager, force a re-scan of devices and see if anything is not right. I am guessing this is an OS problem. You can try booting another OS on a CD/USB like the Windows install just to see if the mouse/keyboard work.Ylian

Leave a Comment

Please sign in to add a comment. Not a member? Join today