Intel QST SDK Linux: Which drivers is needed HECI or AMT?

Intel QST SDK Linux: Which drivers is needed HECI or AMT?


I am trying to use the Intel QST SDK on my DH55TC motherboard. From Debian Squeeze.

The Intel QST SDK documentation talks about installing the heci driver from

This one is outdated, and needs some patches to get going on newer hardware. The patches are available in pdf documents, so not very smooth. See

On the other side I understand that the new Intel AMT Open Source drivers contain the MEI drivers, which are basically successor of the HECI driver or a superset of HECI

drivers. These can be downloaded from

This driver doesn't compile on Debian Squeeze, see

So I am kinda stuck here.

Would love to have someone shed some light on this.


5 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

I solved my compilation problem (mentioned above), and got the AMT/MEI module loaded correctly.The sample applications in the Intel QST SDK now run correctly.So it seems that the HECI driver from is no longer needed.Would be good to have some official info from Intel though.

Hello opperpanter,how did you solve your problem? If i run one of the example sdk programs i always get a ERRNO 19 (no such device). The mei and SDK does compile and the mei module is loaded.I changed /dev/heci to /dev/mei in the device library sources, but this doesnt helped me.Hopefully you can help me.Bye

I don't think you should (need to) change the device name. If I remember correctly, the QST SDK doesn't use the device by name so it wouldn't matter.For me it just works If I add the one line to the MEI source and compile & load it.

I am having the exact same problem - ERRNO 19 (no such device).

I tried strace on the bustest program and it showed its trying to open /dev/heci. So I thought maybe I could symlink /dev/mei to /dev/heci. Now it shows

ioctl(3, HIDIOCGRDESCSIZE or HIDIOCGVERSION or SNDRV_HWDEP_IOCTL_INFO, 0x7fff63b5e290) = -1 EINVAL (Invalid argument)

Is it because the QST SDK was written to use the older HECI driver thats causing this problem?

I am not a programmer so I do not know what's the next step to take from here. Can anyone help me?

I am running Fedora 15 x86_64 on a Q35-based machine. The mei module compiles and loads fine.


Leave a Comment

Please sign in to add a comment. Not a member? Join today