RemoteControlTyped.exe aborts when trying to enumerate registeredprofile

RemoteControlTyped.exe aborts when trying to enumerate registeredprofile

Hi all,
I am fairly new to using the SDK. I have a AMT 6.0 capable HP Elitebook 8440p and I use the latest SDK(6.0 with hotfix 2450). I followed the instructions in the readme of the sample for Remote Controland was able to compile the remotecontroltyped.exe application. However when I run it I get a

"Debug assertion Failed"
Expression: Map/Set iterator not deferenceable

The failure is happening in CimObject.cpp when trying to do:
client->Enumerate(resourceURI, xmls, &selectors);

It is actually trying to enumerate the RegisteredProfile as part of DiscoverManagedHost().

Does anybody have any ideas on how to get around this?

Here is how I run the program:
remotecontroltyped.exe -c -verbose -host 192.168.x.x -user admin -pass abcd

Appreciate any help I can get.

Sudarsan VS.

7 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Can you try using the pre-built executable sample located in the SDKin the folder:

(there is a C# sample too)

I just ran this successfully on an AMT 6.0 system with the options you are using.

Hi Lance,
Thank you for the idea. I tried it and was able to run it without any abort. But I see the following error:

C:\intel_amt\Intel_AMT_SDK_6.0_Hot_Fix_2450\Windows\Intel_AMT\Bin\Ws-Management\C++>RemoteControlTyped.exe -c -host 192.168.x.x -user admin -pass

Exception string error: Failed to establish a connection with the server.

Openwsman last error = 12029

Do you know what this means and how to get around it?

Sudarsan VS.

Best Reply

Looks like you are having a network connetion issue.

Fot the -host parameter you need to put in the valid IP address for the client or its hostname. You can test first using ping to see if the client is reachable for example: ping

If ping doesn't work you need to make sure your network is setup properly.
If pingdoes work but still get failure of AMT commands then you may have a firewall blocking the traffic.

Thank you Lance. It was indeed the firewall blocking traffic. As soon as I disabled firewall it worked. I still need to figure out how to make my compiled code run instead of the pre-compiled code. I did not make a single line of change to the code and still keep getting the Debug assertion failure when it calls the DiscoverManagedHost() for RegisteredProfile Enumeration. I will keep trying things out and report back what I find. If you have any ideas on what I could try out, please do let me know as well.Regards,Sudarsan VS.

Hi Lance, Finally, I got around it just by compiling the C# version of code. The C++ version of code is still having trouble, but at least I have a way to keep going.Thanks for all your help.Regards,Sudarsan VS.

Glad that is working for you.

For the other sample, please take a look at the readme in the sample directory for notes on compilation, especially for debug build dependencies.

Leave a Comment

Please sign in to add a comment. Not a member? Join today