AMT client does not respond to Power Down

AMT client does not respond to Power Down


We are facing a strange problem with AMT client PC. When we try to power down from DTK Terminal application (version 0.52) the AMT client does not respond. We even tried to power down from IE using :16992">http://:16992 but failed there too. We have seen power down was working earlier but looks like something went wrong somewhere. We have 2 AMT PCs and our client also has similar AMT PCs. The problem is seen in all these machines. All otheroperations in Terminal applicationseems to be working fine.

We tried resetting the AMT client to factory default but received the same error. But when we tried topower downusing DTK ver. 0.48 the problem disappears. Is this a known issue in DTL Terminal ver. 0.52 which is causing this problem? Can someone confirm this or suggest what could have gone wrong?

Our AMT PC has the following system information:

Dell OptiPlex 755 with BIOS ver. A08

Baseborad Product Name: OGM819

Our Client has the following AMT PCs:

Dell OptiPlex 755 with BIOS ver. A01 and ver. A03

Thanks in advance,

Vengada Varathan.

5 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

You have an interesting problem for sure. I have not seen this with version 0.52, however I usually only have one AMT Client at a time usually. It's also interesting that you are not seeing this with version 0.48.

Does it work if you disconnect from the AMT Commander, reconnect and then power down? I'm wondering if there is something going on with your IP addresss causing the AMT Commander to become confused. Do you have a utility where you can examine the network packets that get sent after powering down? It's not a firewall issue is it? Would your Dell for some reason be blocking traffic from internet connections?

And now for the unfortunate news (although it's good news for the owner of the AMT Commander) - he is currently enjoying his Intel Sabbatical and won't be back for quite some time. Weeks, actually. At this point, if version 48 is working for you, I'd go back to that one until either you determine if it is something on your side or we find out that version 52 has an issue with powering down.

If you find something in your environment that is causing this, please let us know.

Follow me on Twitter: @GaelHof

Thanks for your reply. It is unfortunate that owner of the AMT Commander won't be back for some weeks. Is there any other possibility of Intel verifying this and confirm? And it this point we are going to use version 48.

We have tried with various options even like resetting the AMT machine but still the problem persists. And there is no other firewall or IP issues in the network and to confirmthatonly Power Down is not working while all other features are working.

Meanwhile it is a very good point to check the network trafic to see what is happening behind the scene. I will check this option.

As an alternative to waiting for Ylian to return from his sabbatical (confirmed in my previous post) you could take a look at the Sample code in the SDK for the Remote power options and use that code. Do you have the source code for the DTK? Maybe you could look at version 48's source code if you have it and see if you can see a bug? I'm afraid that would be your quickest way to getting this fixed at this point.

Follow me on Twitter: @GaelHof

Hey sorry for replying you late. We have all the source code for DTK.

Actually we have decided to go with .48 version of DTK. And if the customer reports a problem we will check the source code.

Vengada Varathan.

Leave a Comment

Please sign in to add a comment. Not a member? Join today