AMT machine remote command line access

AMT machine remote command line access

We have oneIntel AMTcapable computer (HP dc7700) which one on some unknown reason locks up after some time, no regularity etc., but access to AMT remain unaffected.I wonder is there a option using Intel AMT technology to reboot this locked up computer using command line in Windows XP Pro? If it is I could set a monitor to run a reboot command using this cli.
More thanks,
Alar from Tartu Uni, ESTONIA.

32 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.


You can use the WebUI (http://ipaddress:16992) to log on to your AMT system from a remote system and can reboot the system. here ipaddress is the IP Address of your AMT client system.



Hi! And thanks!
I'm aware of this. I didn't pointed this out,butI need to reboot this computer using another so. called watchdog-computer. Last time this lockup happen 2 AM.
More thanks, Alar.


The Remotecontrol sample in the SDK can be used for rebooting your AMT client from the Management system. Are you planning to call this command from a program?



Hi and thanks again!
I think good to have in mind both options, I mean running from dos prompt and also from program. First one is more ... flexible, I think. And ... even better when there is no need to install much of stuff for this little task. =) I saw a sample with terminal, but there was for command line just logon credentials and, well, within SDK.
More thanks, Alar.

Hi again!
I try RemoteControl from SDK (seemsgood enough for my current task),but get error:
"Calling function GetSystemPowerstate...The WinRM client sent a request to an HTTP server and got a response saying the requested HTTP URL was not available. This is usually returned by a HTTP server that does not support the WS-Management protocol. Exception caught".
Probably I missed something, but what? Any ideas?
More thanks, Alar.


Are you able to log into your client from the remote system using webUI? For this, open an Internet Explorer window and type http://ipaddress:16992. Please make sure that you have turned off the firewall.



Hi and thanks!
Yes, via Web UI is access OK. And I setup Altiris OOB also(and HPCMS)and access with TDK is OK! (Thanks to Ylian Saint-Hilaire and others in this community!)
But via command-line I get this error.
More thanks, Alar.


Which Operating system are you using here?



Hi and thanks!
Windows XP SP2. WinRM is set up with config as was described in this forum before.
More thanks, Alar.

Hello Alar,

We will need to get more detailed information about your issue. First, have you seen this blog? We need to make sure WINRM is configured correctly. Could you include the following:

  1. Results from running >winrm get winrm/config/client (see the blog included here)
  2. What is your operating environment? Enterprise or SMB?
  3. Static IP or DHCP?
  4. What is the exact error that you are getting (can you include a screen shot?)
  5. What is the exact command that you are issueing?

(Sorry if you already answered some of these questions - I just want to get enough information together in one place so that we can troubleshoot this a little faster.)

Hi and thanks!
Probably, I think, something I'd or have here wrong as I'm not good at this.
(1) Yes, I configured this exactly by this blog You mentioned. I hope I'd it correctly.
NetworkDelayms = 5000
URLPrefix = wsman
AllowUnencrypted = true
Basic = false
Digest = true
Kerberos = true
Negotiate = true
Certificate = true
HTTP = 80
HTTPS = 443
TrustedHosts = *,10.0.*
(2) Enterprise. This was suggestedfor Altiris OOB.
(3) Error is as "Calling function GetSystemPowerstate...The WinRM client sent a request to an HTTP server and got a response saying the requested HTTP URL was not available. This is usually returned by a HTTP server that does not support the WS-Management protocol. Exception caught".
(4)Command is "RemoteControl -p -host -user Alar -pass ".
Intel AMT v. 2.1.2 and 2.1.3.
I have full access via Web UI and also with TDK.
More thanks, Alar.

One of your earlier responses indicates you are running Windows XP? Could you verify which OS is running on your AMT Client and which OS is running on your remote console? (you are running the sample from your remote system, correct?)

OS: (From the readme file) But this is contradictory to what the system requirements page says.
Since WinRM can be found only on Microsoft Windows Vista OS, these samples can run
only on this OS. (I am checking on this statement!)

I'm also wondering if you need to modify your Trusted Hosts - The blog instructions have "localhost" added in addition. You might also want to enter the actual IP address instead of using the asterisk. From Ajith's Blog:

  • TrustedHosts = *,myAmt1,,localhost

A couple more things to verify:

WinRM: (Again from the readme file)
To make these samples work make sure that WinRM has been activated and that a WinRm
listener is working.
Follow the next steps to make sure that WinRM works:

1. Type the following line in the CMD:
winrm quickconfig (configures the listener that accepts connections from every network interface)

To see the configuration type:
winrm get winrm/config (you have done this - make sure TrustedHosts is set correctly)

To see the list of Listener:
winrm enumerate winrm/config/Listener

I hope this helps!

Hi Again,

I have some more information. The SDK Documentation says that Winrm is only available for Windows Vista because it was written before Microsoft included it for the other OSs. So you should be OK OS-wise. I have put together another blog with some more reference links that hopefully you should find helpful.

I think you are very close to getting the sample to work - you shouldn't have to do much more than what you have already done. One thing we need to find out is that you mentioned you are running Intel AMT in Enterprise mode.Did you provision with or without TLS? It is possible that the Remote Control Sample is hard coded to only to use HTTP/Digest Authentication(SMB or Enterprise non-TLS.) If this is the case you would have to modify the sample code in order to have success.

You might want to simply try provisioning your system in Small-Medium-Business mode and see if you can get it to work.

Hi and thanks!
(1) Yes, I am aware of this Vista requirement, but I thought - maybe wrongfully - that WinRM for XP meet the same requirements.
(2) I have Enterprise non-TLS.
(3) Yes, I'm running this program from mine XP Pro computer and on remote (destination) I try to connect with machine OS not running at all on it, so called, if I'm correct, out of band (OOB) situation. This is my goal as I described in first post.
(4) I'd add localhost to trusted, but situation same. Also, full IP does not change anything.
I rather prefer do not change provisioning as I'm using Altiris OOB and HPCMS and this might interfere here.
Something I misunderstood?
More thanks, Alar.

Well... After all these questions and answers, I seem to have overlooked one simple thing. WS-MAN is not supported on AMT 2.x. In fact,WS-MAN is not supported until AMT 3.0 - your HP dc7700p is an AMT 2.x flavor. Note that the current SDK supports both AMT 2.x and 3.x firmware. One thing I can say is that in about a month we will be putting a WSMAN Translator onto the Manageability Community Site that folks having AMT 2.x firmware/Hardware will be able to use for running the WS-MAN samples.

Sorry about that.

Gael Gael Gael... This is why people should use the Intel AMT DTK! As part of the Intel AMT DTK source code, I have a small sample project called "IntelAmtCmd". It's a windows console prompt tool that can be used to power on an off Intel AMT computers. Also, it works with all version of Intel AMT. You can also change it to do just about anything, great for people getting started on there own projects.

Just to gloat, since the release of Intel AMT DTK v0.51, it has it's own built-in WSMAN stack so, it does WSMAN just fine without WinRM (which was a real pain).

If you don't want to compile the IntelAmtCmd tool, let me know, I may just include it as part of the next version of the DTK binary.

Ylian (Intel AMT Blog)

Ylian to the rescue! :-) Thanks - this is good to know!

Yilian, So are you saying people can use WinRM to send WS-MAN commands to AMT 2.0,2.5, and 3.0 using the DTK?

Hi. SOAP is supported on all versions of Intel AMT andWSMAN is supported starting with AMT 3.0. Microsoft WinRM is a COM component that help with WSMAN so, you can only use it with AMT 3.0 and higher.

If you read my blog you will know that I am very annoyed with WinRM since it's just too complicated for most people and in the latest DTK I got rid of it. I now can do WSMAN using my own C# code.

If you use the Intel AMT DTK stack (IntelAmtStack.dll). I hide SOAP/WSMAN completely and so, you don't have to worry about it. In the future, we will have other solutions for this.

Ylian (Intel AMT Blog)

Hi and thanks!
Gael, I hope You'll solve this also for AMT 2.x as there is many computers out there with this version of AMT.
And thanks, Ylian. This IntelAmtCmd is more promising, but when I run it stay as "Connected." and ... that's it.
On target machine I have AMT 2.2.1 and no problem accessing it with AMT Commander or via Web UI.
Any ideas?
More thanks, Alar.

If you can, try to load the course code to IntelAmtCmd into Visual Studio and step thru it. Are you saying the it's making a call for the reset but it's not working? I would check the command line arguments. In any case, I will try it myself to see if it works.

Ylian (Intel AMT Blog)

Hi! And thanks.
I'll try this tomorrw, here is already 20 PM and ... must go home! =)
I tried power on.
intelamtcmd -u:Alar -p: -c:poweron
More thanks, Alar.

Sorry, forgot.
Connecting to: / Alar


Hi again!
Ylian, any luck with this? Anyone else?
More thanks, Alar.

Arg, I have not have time to look into this yet, I am overflowing with work. Are you using Visual Studio with the source code to run IntelAmtCmd? Also, when you perform remote control operations with Intel AMT Commander, go in the custom operations dialog box and you will see at the bottom of the form the values that will be used to execute the operation. I suggest trying with Commander and then using these same values and just placing them into the souce code of IntelAmtCmd.exe...

If you at not looking at the source, this will be of no help, I will have to take a look at it. It's difficult right now, I am so excited about the new things I am working on, I am piling up a long of work in my inbox.

Ylian (Intel AMT Blog)

Hi and thanks!
I'd take a closer look and, (1) yes, values was different for remote commands, but also (most important), (2) commands section was commented out at all, I didn't noticed this before. =)
It does work now, many thanks, just wonderful. Now I have a tool for OOB remote operations from command line in Windows Thank You!

Glad to hear that you got it working Alar. Thanks to Ylian for the support. You know that this is a forum and we would really appreciate if the developers like you can contribute your learnings here that would help out others. Please feel free to chime in on any questions on this forum to share your learnings.

Once again, if you have other questions, please post them here and we will try to get them answered. Thanks for using the manageability forum.

Gael... you got your revenge and proved me to be really blond. Indeed, in the latest version of the Intel AMT DTK, my small sample IntelAmtCmd has the remoting code simply commented out... hum... That was really silly of me. I will fix it in the next release.

For people looking at that sample, once you get the Intel AMT System class connected, you can do a lot of cool things like access hardware inventory using "Computer.Assets.GetBios()", you can play with all of the features of AMT without worry of WSMAN, SOAP and anything else. Just keep in mind that some features don't exist on some version of Intel AMT. So for example, "Computer.Wireless" will be equal to NULL on all AMT versions except AMT 2.5 that supports wireless.

Also, you can connect the same AmtSystem object to LMS (local connection). Just do that same thing as connecting to a remote computer, but instead connect to localhost. The stack will detect that it's talking to LMS automaticaly and you can do all of the things Outpost does with LMS.

Thanks for figuring it out.
Ylian (Intel AMT Blog)

Hi again!
One thing I noticed. May be this is by design, but ... this could happen. When I send "poweron" command while computer is starting or started then on operating system level machine does hang on.
More thanks, Alar.

Hi Alar,

Thanks for sharing your insight. I want to understand this a little more. When you issue a power on command while the OS is starting to come up or has started to come up, you are observing that the OS is hung and does not continue to boot. For how long is the OS in hung state or it doesn't recover at all?

Also another good habit is to first to get the current power state and then issue the subsequent commands accordingly. If the system is already powered on, there is no need to power it on again. This could avoid problems like the one you mentioned. Although its very strange that the OS is getting hung. Keep us posted.


Hi and thanks and sorry for delay!
I totally agreed about habits You describe. In my case this happen by accident, just did send a command twice. But, anyway, is this kind of situations avoidable not relying on peoples habits?, I mean, mistakes happen.
I noticed that machine hung and nothing helps but button or reset-command via AMT. Hard to say for me something 99% sure what was exact cause of this kind of problem -- faulty hardware or something else.
I haven't tried this on another AMT-capable machine, I'm not very happy when machine hang on. =)
More thanks, Alar.

Leave a Comment

Please sign in to add a comment. Not a member? Join today