IAmtTerm.exe

IAmtTerm.exe

We publish our platform for example
in directory C:Documents and SettingsAdministradorConfiguracin
localApps2.03T3XXMXZ.T67AANV7KO8.LQ3iris..tion_14401e6ba0f9b9b1_0004.0006_b89d62328bf13217,
and in this directory the application IamtTerm that we attach doesnt work, and
in other places it works perfectly.

We need this application works in
directories like these.

Thanks in
advance.

Best
regards.

10 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Raul,

Thanks for the question. We are looking into this issue and hope to get back to you soon.

Hi,

I just tried running IAmtTerm.exe in the folder you mentionned and it works. I think your problem is a different one, IAmtTerm has dependencies and so, you need these 4 files:

IAmtTerm.exe
IAmtControls.dll
IAmtRemoteStack.dll
imrsdk.dll

If you have these 4 files in the same folder, it would work.

Hope it helps,
Ylian (Intel AMT Blog)

I have these 4 files in the same folder... of course. Could you give me the files that you tested?

I just used the 4 files out of the latest version of the Intel AMT DTK. It is rather weird that when one of the dependency file is missing, the DTK tools will just show this very bad error message with no clue as to what is going on. Of course, the DTK also relies on Microsoft .NET Framework 2.0, so you must have that installed on that computer.

If the DTK otherwise works on that computer, I think you should play around with it, removing files from the DTK until you have the minimum set. I did try it on my computer and it worked well.

Ylian (Intel AMT Blog)

What version do you test it?

I just tested it using version v0.34, it is now released.

Ylian (Intel AMT Blog)

If i tested v0.34f in C:APLI+Dbis runksrcIRMServerPlatformsPlatformSmartClientIrmSmartControlWininDebug it doesn't work: i obtain disconnected result, but in others directories it works perfectly. I have the same permissions in all directories i tested... i don't know what is happening...

Do those other directories have the "+" sign in them? Sometimes I experience problems if my path length is excessively long as well.

Follow me on Twitter: @GaelHof
Facebook: https://www.facebook.com/GaelHof

Exactly with v0.34f (last version i have) the application IAmtTerm.exe has problems with some directories.

I have these directories with the same permissions and IAMTControls.dll, IAMTRemoteStack.dll, imrsdk.dll and IAmtTerm.exe, and the result is:

- For example in C:DTK+2 it works perfectly.
- In C:Documents and SettingsAdministradorConfiguracin localApps2.03T3XXMXZ.T67AANV7KO8.LQ3iris...exe_1df129fea8a2a115_0004.0005_none_e9e0a3f08e736d6b,
we obtain disconnected result.

- In C:APLI+Dbis runksrcIRMServerPlatformsPlatformSmartClientIrmSmartControlWininDebug, we obtain disconnected result, too.

We have integrated this application with our platform and we need it could work with directories like
C:Documents and SettingsAdministradorConfiguracin
localApps2.03T3XXMXZ.T67AANV7KO8.LQ3iris...exe_1df129fea8a2a115_0004.0005_none_e9e0a3f08e736d6b

Best regards

Leave a Comment

Please sign in to add a comment. Not a member? Join today