Problems with vPro actions

Problems with vPro actions


We have the problem that when we try
send reset command, we obtain http protocol error. I attach an


Downloadimage/jpeg error.JPG56.04 KB
13 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Raul,

Can you give us more information on the configuration parameters? It would help us if we know the AMT firmware version, BIOS version, SDK version etc. What mode is the client configured - SMB vs Enterprise? Please let us know the details.

I am assuming that you are using http SOAP interface. Please make sure you are using the correct connection parameters (IP address, port, user credentials etc.) Protocol error could be because of the incorrect usage of the API.


The application is the same that i used with other PCs and we didn't have any problems. I use SMB mode and the params are correct. Could i send you by mail a simple sample for test it?

Hi. The screen shot shows that you are getting an "Access Denied" error. There is probably nothing wrong with the application, as you say, it works on other computers. Thiserroris coming from Intel AMT. Of course, check that other SOAP commands work and that your username and password are ok (but I am pretty sure this is not access denied due to a bad password).

The first thing I would do is update the BIOS/AMT firmware, older firmwares for Intel AMT 2.0 have such problems. Also, if the Intel AMT computer is in the BIOS screen or in a state where it can't reset, you may get this error. If the computer is already sleeping, you may get this (check the SDK for a table on correct commands). I also know that if you are trying to send a "Power Down" command while IDE-R or SOL sessions are active, you will get this error. Just to check, make sure no IDE-R and SOL sessions are active.

We have seen this before, I remember a post on this forum about this problem. It's likely a firmware update could fix this.

Ylian (Intel AMT Blog)

We are desperate... we don't have SOL active and we have updated BIOS and we obtain the same error... What can we test? It is very simple: we are working with Small Business mode with user and password...

A simple test application is in:

Please, we need help...

We use:

"http://" + this.amtIpAddress + ":" + this.amtPort + "/RemoteControlService";

We believe this web methods have changed, because this funcionality return error now, and before with the same source code, everything worked perfectly...

Ok, I will try it today and send back the results. The web methods should not have changed, but I don't completely understand why Intel AMT sometimes can't reset or power-down a computer. I will mail back later...

Ylian (Intel AMT Blog)

Hi again,

I just tried your application and entered an ip address and the administrator password and hit reset. The tool just locked-up. I would try to reset using the SDK samples, the new Intel AMT SDK 3.0 was released and I would try that first to see if it is your tools or Intel AMT that has a problem.

Ylian (Intel AMT Blog)

We don't understand...

If i do a simple C#.NET project with a web reference: http://IP:16992/RemoteControlService (Network Interface Guide.doc), we obtain error 401: unauthorized... we can not access to this WS...

Please, it is very urgent... we don't know what is the problem...

Can you verify for us that you have done the things that others in this thread have suggested? Also, please review the SDK doc that discusses Redirection - there are things that need to be done before you can successfully have a SOL/IDER session (like enabling the ports)

Follow me on Twitter: @GaelHof

I have done all the things that in this thread have been suggested and we have reviewed documentation. But i don't understand, i don't want a SOL/IDE session, this works perfectly. I only want to have access to a web method to http://IP:16992/RemoteControlService.

Please, we need help... it doesn't work...

We have studied too IntelAmtCmd and IntelAmtRemoteStack, class AmtSytem.cs, and we obtain FAILED_WEB_CALL...

Leave a Comment

Please sign in to add a comment. Not a member? Join today