Problems Provisioning AMT machine with USB

Problems Provisioning AMT machine with USB

Hi Ylian and Holmes,

I have problem configuring AMT machine with USB. I inititally configured AMT in small business mode to test features with AMT Commander, it worked.

Then I un-provisioned AMT (I think I did it correctly), used create_usb_file.bat (I modified this batch file a bit) to format usb and it created the setup.bin file in the usb. but it is not configuring AMT with PID/PSS,

I plugin usb, start pc (pc is now in factory mode), but it does't reads PID/PPS from USB ..

-Note: I unprovision AMT by selecting an option in Managebility section, it shows three options 'None', 'Intel AMT' and 'ASF', I select 'none'.

Sohaib

6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Sohaib,

Note that I spit this post off from the other subject where you had entered it. Ylian will prbabably need to chime in on this one, however when your system is in factory mode, did you make sure you set the ME password back to the default password (I think USB provisioning requires this.)

I think you probably also might want to try selecting "Intel AMT" in the unprovisioning section.

Also, which AMT platform are you running and with what version of the firmware?

Hi Ylian,

I did't try make password back to default password, Platform is version Intel 2.x

Firmware version is 2.0.5.1124

Product version is: AAD41676-400

I tried to change the password back to default that was 'admin', thats not a legel (strong) password, the platform does not allow it.

I think I am not able to fully unprovision the platfrom, and I cannot see any option there to full unprovision the mahine ....

- Sohaib

You should leave the following set to 'AMT' in the MEBx:
Intel ME Configuration->Intel ME Features Control->Manageability Feature Selection

Changing the above does not unprovision the system.
To unprovision a system enter the following location of the MEBx and select 'Full Unprovision':
Intel AMT Configuration->Un-Provision

You are correct that you must have the default password set to 'admin' in order to have the USB key load the triplet, but as you have discovered once you change the password you cant change it back. This is true even if you successfully perform a full unprovison. The only way to reset the default password is to remove the battery on the motherboard.

Hi,

There is no option to UnProvision there. All I can do is set it to 'None' or 'ASF' or 'AMT', there is also another option where I can choose between 'SBM' and 'Enterpise' mode.

Does the PID/PPS pair entry by USB need the password to be default('admin'), it means that if one changes the password, then one has to remove battery to use usb for this purpose ?

- Sohaib

Hi there,

I have posted the same solution in another question on this forum:

Firstly i notice that your AMT firware is not totally up to date, could you please tell me what type of hardware you are working on?

My first advice would be to update your AMT firmware and BIOS to the latest version. Then once this is done you can try to return the system to factory mode, this will fully unprovision the system for you. I know for a fact that the "full unprovision" option does not work correctly on most systems. There is a workaround, but to do this is differant from vendor to vendor, here are some steps you can follow.

HP DC7700: Remove the power cord and open the case. Wait for about 10 seconds for all energy to dissapate. You should see a small yellow button behind one of the ram slots. Press this button and hold it in for about 20 seconds. Now put the case back on and put the power cable back in. Power up the system and allow it to boot through to the OS at least once. This is to allow the BIOS to update itself. You will get a warning about the system clock needing to be set, you can ignore this for now and set it later. Once the system has been through a single boot cycle you can perform normal enterprise mode configuration.

Intel based systems: There is a BIOS configuration jumper on the mother board, refer to your documentation for its location. You need to move the jumper to the next pin (i.e from pins 1-2 to 2-3 or however your documentation indicates). Please remember to do this with the power removed. Once the jumper has been moved you can power up the system and you will enter a special BIOS configuration screen automatically. Select the setting that says "Return AMT to factory mode", im not sure of the wording but it should be recognisable. Save your settings and then remove the power again. Place the jumper back in its orriginal location and power up the system. Power up the system and allow it to boot through to the OS at least once. This is to allow the BIOS to update itself. You will get a warning about the system clock needing to be set, you can ignore this for now and set it later. Once the system has been through a single boot cycle you can perform normal enterprise mode configuration.

Fujitsu Siemens: I have had trouble provisioning fujitsu siemens boxes (see the post in this forum) but i can tell you how to reset the AMT, simply remove the power and then remove the battery. Wait for about 30 seconds and then replace it. Power up the system and allow it to boot through to the OS at least once. This is to allow the BIOS to update itself. You will get a warning about the system clock needing to be set, you can ignore this for now and set it later.

To provision the systems you can now follow the standard procedure as described in the online documentation. There is a quick test that i use to tell if the configuration was read successfully, go into the AMT bios and try to logg in with the admin password, if this fails then your configuration was updated.

Leave a Comment

Please sign in to add a comment. Not a member? Join today