HP DC7700

HP DC7700


I'm currently testing our software against HP DC7700's and have encountered a problem that I hope someone can help me with. The problem is as follows:

The HP systems BIOS was very old, v1.05. As this version is known to have problems i updated the BIOS with v2.10 (The version for systems with Intel ME).

After the upgrade my BIOS gives the following system information:

  • System BIOS = 786E1 v02.10
  • ME Firmware Version =

During the boot process there is a period where the ME information is displayed. Everything seems to go well, however after the "ME-BIOS Sync - Sucessfull" an error is shown.

2218-ME Firmware Version should be updated.

ME BIOS Extension module execution has halted. Update BIOS or Management Engine firmware if problem persists.

Can anyone please tell me how to fix this. I just updated the BIOS with the latest version available from the HP website.

12 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

There are 3 things that need to be updated;
Management Engine (ME)
AMT Firmware

It looks like the HPQFlash.exe utility does not upgrade the AMT firmware. Just the BIOS and ME.
You are receiving the message because the BIOS and ME got updated, but not the AMT firmware.

To update the AMT firmware from within Windows: (You will need to have the HECI driver and LMS service installed)
-Open the 'ME Flash' folder of the BIOS download from HP
-Copy 213_1031.BIN to the 'ME Flashlocal-win' folder
-Open a command prompt and point to 'ME Flashlocal-win' folder
-run FWUpdLcl.exe with the -generic switch
FWUpdLcl.exe -generic

Thanks for the update and sharing your knowledge with the forum.

Thank you for your speedy reply. I am familiar with the HECI driver, but can you tell me what the LMS service is?

HP has it available in their drivers download section under the name 'Intel Local Management Service (LMS) and Serial-over-LAN (SOL) Support'.

"The Host Embedded Controller Interface (HECI) driver is a software interface that is used to communicate to the Intel AMT subsystem (Management Engine) to access Intel AMT capabilities. Communication between the local host operating system (OS) and the Management Engine (ME) is accomplished by means of the HECI driver. HECI is bi-directional, as either the host OS or Intel AMT firmware can initiate transactions.

The Local Manageability Service (LMS) is a service that runs locally (in the user space) in the host operating system. LMS listens for the request directed to the Intel AMT local host and when a application sends SOAP/HTTP message addressed to the local host then LMS intercepts the request and routes the request to the Management Engine Interface via the HECI driver. In short, the LMS enables local management applications to send requests, and receive responses to the local Intel AMT device."


Just to clarify, LMS runs as Windows Service.

Thank you for the clarification. I'm not sure if this is the right place to mention this, perhaps i should complain directly to HP. I found the drivers for Windows XP and Vista, but I am unable to get them for Windows 2003. All our clients HP dc7700p systems are running Windows 2003. So the only way i can fix their systems is by installin xp, performing the update, and then restage the systems 2003 Images.

Any advice would be most welcome. Thank you again for all the help so far.


Sorry about the inconvenience you are having but I would recommend contacting HP for the drivers.

Thanks for using the forum.

Awaking an old thread here... hoping for some response anyway...

I have trouble completing FWUpdLcl.exe -generic to resolve the problem with a halting BIOS.

I'm running Vista Ultimate 64bit on a DC7700 SFF. The machine runs after bios-update but I get the error message at boot up. Also every second time I boot the machine halts after BIOS error message. I need to cycle power twice and THEN i boots Vista fine.

So, after Googleing a while I conclude that I need the FWUpdLcl.exe -generic solution to run. When I run it all I get is an empty command prompt. Nothing runs - not to be seen anyway. I installed LMS and tried to install HECI but when running the softpaq for HECI I get an error message saying the program cannot run. Is that perhaps an 64 bit issue ?

Any tips and ideas?

Forgot to say that I have tried running HECI in XP compatability mode in Vista 64bit.

There is a Vista64 driver for the MEI, so you need to be running that driver. The XP32 driver should work just fine for Server2003. As said before, you should contact HP to get the latest drivers and firmware.

Quoting - rogerb

There is a Vista64 driver for the MEI, so you need to be running that driver. The XP32 driver should work just fine for Server2003. As said before, you should contact HP to get the latest drivers and firmware.

Thank you.

I found a version of the HECI driver that installed fine on my machine. Rebooted and ran:

FWUpdLcl.exe 221_1034.BIN -generic

Voila! Error message is gone. The one about halting BIOS...

BUT I still have the trouble of the power cycling thing every second time I reboot. I installed the AMT managment client and it reports AMT is dissabled. I then configured AMT via ctrl-p but this makes no difference.

Any ideas on the power cycling? Can I revert to an older versions of the BIOS or the Management Engine (ME) or the
AMT Firmware as this wasn't an issue before the upgrades. Where do I find older versions?

Regards Jonas


You need to contact HP for getting the latest versions of the bios and drivers. The issue you are seeing now will be fixed once you have the proper drivers and bios installed.



Leave a Comment

Please sign in to add a comment. Not a member? Join today