Boot to redirected floppy with boot manager

Boot to redirected floppy with boot manager

Hello,

I have my iAMT PC with two disks in RAID mirror, and this RAID has got 3 partitions.
First one is simply a bootable Vista system partition, second is intended for data and the third is bootable WinPE partition. Active is the first one, so the user always gets directly into Windows Vista.

Now I would like to have an option to remotely force the PC to boot to third partition. I decided to give a chance to the IDE-R so I would like to be able to boot into a remote floppy disk (or floppy disk image) with boot manager (like GRUB or Windows Vista boot manager) on this floppy so I could decide (through SOL) which partition (of the internal HDD) to boot from in the next step.

GRUB has got nice command line environment and also some serial redirection option and bootmgr of Vista could be also piped through SOL so this should be not a problem.

I got GRUB floppy image from http://gazonk.org/~eloj/articles/emergencybooting.html

commands to boot the WinPE partition are:
rootnoverify (hd0,2)
chainloader +1
boot

and the the Vista bootmgr floppy is build as described on http://www.windowsbbs.com/showthread.php?t=55427.

Both floppies work perfectly fine if the USB floppy drive is attached directly to the PC.
Anyway, I can not boot
to remote floppy with GRUB (just hangs) nor Windows Vista boot manager (error
screen in attachement). I can remotely boot only to a simple DOS boot floppy.

does anyone have any idea why the boot managers do not work over IDE-R ?

thanx

Zdenek

AttachmentSize
Downloadimage/gif bootmgr_vPro_Error.GIF45.27 KB
13 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Thanks Zdenek,

I am always looking for interesting new boot images to do IDE-R with and your links are very interesting, I will download the images sometime today and try them on my own computer. I don't know why it would not really, hoping to have a solution for you.

I see your using Intel AMT terminal as a stand alone application, cool!

Mail back soon,
Ylian (Intel AMT Blog)

Hi Ylian,

I have got some additional info to this issue. I have tried to make an ISO bootable image using the above mentioned floppy image of Windows Boot Manager. The results are:

1. if the bootable ISO image is made with no emulation option - same error as above
2. if the bootable ISO image is made with floppy emulation option - I will see the boot option selection screen through SOL, but i can not select. fortunately after a while the timeout forces to boot the first option (WinPE) and I have completely different error (attached).

I also tried to boot the DOS floppy and tried the Grub4DOS, but it looks like it can not see the hard drive at all. But maybe this is because I have only NTFS volumes (DOS unaccessible) or because I have got two disks in RAID mirror.

Zdenek

Attachments: 

AttachmentSize
Downloadimage/gif bootmgr_CD_vPro_Error.GIF45.46 KB

Hi Zdenek,

I hope I can find a solution for you, I have been overloaded today so I did not get to try the boot disks. I never personnaly tried to create a floppy image file, one thing I did do what use IDE-R to start a redirection of a blank floppy and after having Microsoft Windows rescan device changes and detect the new IDE-R floppy, I would then add files to the floppy. This probably does not work for non-DOS OS's, not sure.

Can you explain this "making a bootable ISO using floppy emulation option"? This is an option in Nero?

Ha yes, DOS will only see FAT partitions on your harddrive, no NTFS.You really need a Linux of WinPE based solution to read these NTFS drives.

Ylian (My Intel AMT Blog)

well, the point is that I would like to have a bootable floppy disk with basically no operating system at all. I would like to have just a boot manager on it, so after I boot from it, I will be able only to select to boot an OS from a partition on the HDD (even if that partition is not the active one).

The thing with DOS and GRUB4DOS was just a sort of workaround, which appears to be useless. I do not think the GRUB4DOS takes care about filesystems - I think it should be able to boot a system on NTFS partition, because I guess it hacks the whole thing from some lower level, bypassing the DOS actually (but maybe not).

I am not using Nero, as I am using "CDBurner XP Pro 3", but I guess the emulation option is something pretty standard to choose when building a bootable CDROM so I guess you will have "making a bootable ISO using floppy emulation option" in Nero and you will see it as soon as you will try to make the bootable image.

As GRUB and Windows Boot Manager failed, I guess I will have to give a chance to LILO. I think only those three boot managers have text interface (could be available through SOL), all others have just graphic interface (or some sort of "text in graphic mode" interface).

well, it looks like some sort of bug in the BIOS

I could not get the LILO working, but I just tried another boot manager, called GUJIN, which can be dowloaded from http://sourceforge.net/project/showfiles.php?group_id=15465&package_id=1... where a pre-made floppy image is available.

The result is very obvious this time. If booted from USB floppy drive attached directly to the system it shows up the available partitions. If booted through IDE-R, it will not find any partition at all - looks like no harddrive is found at all.

I give up. I suspected the RAID controller that it does not work properly with redirected boot but now I have got just one disk and no RAID at all and the symptoms are still the same:

when booted from redirected floppy, the boot managers are not able to find the harddrive(s) and if I boot to DOS based floppy and run FDISK it says "No fixed disks present."

I am using the latest BIOS Update 5869 [CO96510J.86A ] and the motherboard is the original Intel DQ965GF. I am using the small bussines mode and iAMTTerm.exe from Intel AMT DTK V.24

Well, I got it !

It
is caused by the BIOS setting: Advanced Drive Configuration Configure SATA
as

(In case of a simple
system with one physical harddrive and no CD/DVD)

If set to RAID (or
AHCI), boot managers and DOS booted from the remote floppy will NOT see the
harddrive (regardless of the fact if there is actually any RAID set up as it
is obviously not possible if there is just one harddrive). When booted from the
USB floppy drive attached directly to the iAMT PC, it will see the drive as it
should.

If set to IDE, boot
managers (booted from the remote floppy or from the USB floppy drive attached
directly to the iAMT PC) will see the harddrive (actually see 2 drives instead
of one due to some emulation or something but never
mind)

So I would say this is
a bug. RAID settings are not compatible with remote floppy boot (I guess it is
the same for remote CD boot).

Zdenek

Hi Zdenek,

Your are so completely over my head. I can't say I know much about RAID. If you have not done so already, this idea of using a Boot manager with IDE-R to boot any partition is a good one and you should submit it in the contest.

I am going to forward your thread to people that know more about this stuff at Intel, I think that if we have an open source do-it-all boot manager to use over IDE-R, that would be great.

Thanks,
Ylian (Intel AMT Blog)

thanx Ylian,

if you could get me some help it would be great because I am out of ideas.

Is there any standard procedure how to report bugs in the BIOS ?

anyway, I just submitted this as an idea to the contest, so you can vote for it :-)

zdenek

Hey,

I will report a bug in the BIOS for you tomorrow. I have collected a few on my own and so, this is a convinient time to add you bug to the mix. There is a standard procedure within Intel and so, it's fall on me to file this bug. I will mail back on the forums once it's filed just to keep me honest.

Ylian (Intel AMT Blog)

Ok, I posted a bug. Of course, I have a bunch of my own pending, so we shall see. By the way, I posted the latest Intel AMT DTK today with many more features and fixes.

Ylian (Intel AMT Blog)

does anyone know if thi sissue was fixed ? Ylian, did you get some reply from the BIOS developers ?

Leave a Comment

Please sign in to add a comment. Not a member? Join today