Cannot download AMT SDK

Cannot download AMT SDK


I've been trying to download the AMT SDK for a couple of days. I've tried before the weekend and today, from OS X, Windows and Linux and from machines in both Europe and the US; nothing worked. The download typically appears to stall for a minute or two, and then results in an empty file. Occassionally, I get a ~2.5MB file, which is incomplete.

The link I used: Download the latest Intel® AMT Software Development Kit (SDK)


- Dan

7 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hello Dan,
I am having same issue and have reported it.
We will respond here again when fixed.

Hi Lance,

It's almost been a month and this still seems to be broken, is there any other way to download or request the SDK whilst the web team are scratching their collective heads? ;-)

My vPro project is rapidly running out of time ...



So sorry Ben - I have escalated the open ticket to get the download working.

Could you try it now? It looks like the download is working now.

no, it is not working... 


I was able to download and unzip the full SDK this morning. I used the Download button link at the very bottom of this page:  Download the latest Intel® AMT Software Development Kit (SDK).

Leave a Comment

Please sign in to add a comment. Not a member? Join today