Intel AMT SDK IntelAMT9.5.0.30Gold sleep/hibernate new features issues

Intel AMT SDK IntelAMT9.5.0.30Gold sleep/hibernate new features issues

Hello! I have downloaded IntelAMT9.5.0.30Gold SDK (I could download it only in IE, because of it's "resume" button - download was interrupted for about 4 times...), and right now i am trying to make the computer to go to sleep (with the new sleep API from sdk 9.x). It fail 100% of times, because: "Requested operation is not allowed in AMT system's current state." error. I tried it on many systems: haswell, ivy and sandy - all same result. The power state of my system was ON - S0. List of supported features from this power state is: soft off, powercycle, reset and NMI (i successfully sent a NMI). I tired it with my own implemented program and with the new "RemoteControl" sample project for amt sdk 9.0 as well, with same results. Please help me to figure out how to make sleep, gracefulShutdown, gracefulReset and Hibernate work. thank you!

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

My haswell system is an Optiplex 9020 with Q85 Lynx Point chipset, with bios updated to latest A05 version.

In Intel MEBx, option Desktop: ON is S0, ME Wake in S3, S4-5 is selected, to enable AMT to run while system is in sleep or hibernate state.


Could you please try to connect to your AMT Client using the Web UI?  See if you can connect and do some simple operations.  The web UI can be accessed via the following URL:  http://<ip address>:16992  if you have configured your client to use TLS security then the port for https is 16993.

You could also see if you can do some basic connection and power control using the DTK:

Follow me on Twitter: @GaelHof

Leave a Comment

Please sign in to add a comment. Not a member? Join today