PSM aborts connecting to vPro 9 client

PSM aborts connecting to vPro 9 client


Today I installed vPSM_1.0.0.11634 and tried to connect to a vPro 9 client. I got the following error:

  Exception: Object reference not set to an instance of an object.
     Source: HLAPI
Stack Trace:    at HLAPI.Wireless.WirelessWSMAN.GetLinkPolicy()
   at HLAPI.Wireless.WirelessManager.GetWiFiLinkPolicy()
   at HLAPI.GeneralInfo.GeneralInfoManager.RemoveWirelessIfNotSupported(List`1& supportedFeatures)
   at HLAPI.GeneralInfo.GeneralInfoManager.GetSupportedFeatures()
   at Intel.Manageability.Impl.AMTInstanceManager.get_SupportedFeatures()
   at Intel.Ucrd.vProPlatformSolutionManager.Controls.CtrlSystem.<>c__DisplayClasse.<ConnectEx>b__9()


  • Management station is a non-vPro Thinkpad using wired Ethernet. My WiFi reports "hardware radio switch is off."
  • Client is a Lenovo M58p with vPro firmware version 9.0.2-build 1345. It's set up in small business mode or whatever the super-simple mode is called (no certificates). I can connect fine through the web interface.
  • I am connecting across a router-based VPN. I used an IP address when trying to connect. I chose to connect using digest authentication and without TLS.
  • I was successfully connecting to this machine a few months ago using vPSM_1.0.0.8980. When that aborted this time, I downloaded the latest (11634) but it still aborts.

I tried connecting to a couple other devices over the same VPN to the same remote network:

  • Lenovo TS140 server, also running firmware version: 9.0.2-build 1345:  crashes with "Max Retry attemps (sic) reached"
  • Dell Optiplex 960 running firmware version: 5.2.40-build 1037:  connects without issues

So it only seems to fail to connect to vPro 9 machines. Any suggestions on how to connect to these machines? Also, it would be nice the if the entire program didn't crash when a connection to a machine fails...



11 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Oops I just saw George's post So this is a "me too."


Yep and you apparently aren't the only ones...   The developers are working to get it fixed and will provide a new release.  I will ask them if there is a work-around, meanwhile.

Update:  The developers are working on a fix - no timeline yet for when a new release would be available.  However, the problem appears to be in the 32 bit version.  Would you be able to run the 64bit version on a 64bit OS?


I'm already using the 64-bit version under Win7 x64 SP1. The path to the executable is

"C:\Program Files\Intel Corporation\Intel(R) vPro(tm) Platform Solution Manager\Bin\"

i.e. it's not in "Program Files (x86)".


Ok.  This didn't work for George, either. (Sorry!)

There is a new version out there.  Please let us know if it is working for you:


Same Error before crashing (64-bit version under Win7 x64):

  Exception: Max Retry attemps reached


Stack Trace:

BTW the "Intel vPSM Start Here.htm" file that is in the root of the vPSM_1.0.0.12092 installer says

Version: Beta Release 2.0 September 12, 2013

I only tested the 64-bit version. I thought this was a tested fix? Have they not been able to duplicate this in the lab?


Is that all the information that you got error-wise?  Our dev team is wondering why there is no date, for example.

Yes, the message was brief and the big area underneath, where I would have expected a stack trace, was blank. I do see this in the Windows Application Log:

Log Name:      Application
Source:        Application Error
Date:          6/26/2014 11:10:13 AM
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      MgmtPC.mydomain.local
Faulting application name: Manageability Outpost Service Control Panel Tool.exe, version: 1.0.5262.11806, time stamp: 0x5387453d
Faulting module name: KERNELBASE.dll, version: 6.1.7601.18409, time stamp: 0x5315a05a
Exception code: 0xe0434f4d
Fault offset: 0x000000000000940d
Faulting process id: 0x%9
Faulting application start time: 0x%10
Faulting application path: %11
Faulting module path: %12
Report Id: %13


Okay I  tried the 32-bit version of vPSM_1.0.0.12092 and it _does_ connect to old vPro machines and to vPro 9 machines across a VPN.

Now I wonder if the version I used before that was working was the 32-bit version ... but you said that 32-bit was the problem before ...


Leave a Comment

Please sign in to add a comment. Not a member? Join today