Management Engine Interface Issues

Management Engine Interface Issues

Hello all,

I'm not sure if this is the bet place to post this, so forgive me if this belongs elsewhere. I did actually find similar issues mentioned in this forum, but none of the solutions suggested seemed to work for me. Rather than bump an old thread, I thought it best to start a new one. 

Anyway, I recently built a rig using a ASRock z97 board. I've updated all drivers but have found that the Intel Management Engine device is not functioning (listed with a big yellow bang in my device manager with a message that says it cannot start and code 10). I've downloaded the drivers from ASRock's own site. In this case, the driver was version I also searched for a compatible driver on Intel's site and came up empty handed. All the drivers for this device that I could find here proved incompatible.

I was speaking with a more tech savvy friend who suggested this might also be related to a problem I am having with Sleep Mode. My PC seems to crash anytime it enters into Sleep Mode (or fail to wake up). There has been no BSOD though.

Other things I have tried include uninstalling and reinstalling the driver (with system restarts between of course), downloading Kernel-Mode Driver Framework version 1.11, making sure my INF is also up to date, and even checking the RAM (I had read somewhere that this issue was sometimes caused by faulty RAM). I should also like to note that my BIOS is the latest version as listed on the manufacture's website. I've already contacted the manufacturer about this issue and their best solution was to do a fresh install of windows. So now I come here in hopes of other insights.

A short list of my system's specifications are below, but if any further information is needed, please let me know.

CPU: Intel Core i5-4670K Quad-Core Desktop Processor 3.4 GHZ
SSD (for boot): Kingston 120gb
HDD: Western Digital 1TB
PSU: Seasonic 520W
RAM: 2x Corsair 4GB
OS: Windows 7 64bit
And of course
Motherboard: ASRock z79 Extreme4

Any help would be greatly appreciated!

26 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

When you installed the ME driver package after doing the framework update, did you get any error messages?

Hi Colleen,

No, I did not get an error messages during installation.


Can I confirm that you have tried (from device manager) the update driver option, and the uninstall- reinstall option?  When you check the properties under driver tab - what do you see?

I have indeed tried updating from the device manager itself, and the uninstall-reinstall option. I'm away from the PC in question at the moment, so I cannot confidently tell you exactly what appears under the driver tab in the properties, but I will supply that info once I get back to the PC later today.

Okay, so in the properties, under the drivers tab, I see the following:


Intel(R) Management Engine Interface

Driver Provider: Intel

Driver Date: 3/13/2014

Driver Version:

Digital Signer: Microsoft Windows Hardware Compatibility Publisher



Could you check a few more things please (in device manager).
1. The device is yellow banged under System Devices group.
2. On the properties pop up - on the Events tab - can you send me those Device messages and also from the Info box below send the Vendor/Dev and Sub IDs (Ven_8086&Dev_1xxx long number  and the Driver name listed in that box (like oem@@.inf).

Then could you also try REMOVING the device from Dev. Mgr and then do a hw scan and bring it back, this time pointing directly to that same oem..inf file?


The device is indeed yellow banged under system devices group.

I'm not entirely sure what event tab you mean, but the ids I see are as follows:

Hardware ids


Compatible ids



And I think the name you are looking for is oem37.inf


When I uninstalled it and did a scan, then looked again, the number was still oem37.inf


I should note though that when I did the scan and it reappeared, it reappeared as fully functional for just about 10 seconds before the yellow bang came back.




So when do you get the error 10?  Or is that just when you go in and see why it has a bang?

I would next try locating the oem37.inf and right click and try an install from that.  The event log I mentioned should be in Device Manager > right click on Intel MEI > properties > the Event tab - top half white box.

Unfortunately I do not see anything that says Event, but the error code appears under the General tab in the white box marked Device Status. It says "This device cannot start. (Code 10)"

I am trying to locate the oem37.inf but it too is proving difficult to find. I have used windows search function with all hidden files and folders visible. I did find a folder called INF(v10.0.13_PC) with a setup application within it though. 

I suggest you try a 9.x driver. The chipset originally shipped from Intel with 9.1, so a 9.1 or 9.5 MEI driver would be worth trying. Be sure to uninstall the 10.x driver first.

I've tried a couple of 9.5 drivers but they all gave me an error upon installation saying they were not compatible. 

I also found one 9.1 driver. v9.1.0.1120_1.5M to be exact. And that one installed successfully but I still get the yellow bang, and oddly enough, the device manager lists that driver as as opposed to 9.1. 

I should have asked - are you uninstalling from both device manager and removing the software from Add/Remove programs (Intel Management InterFace).  If not , that's possibly why the rollback to 9.5 would be failing.  

I had not thought of uninstalling it through the Add/Remove programs list before. I had been uninstalling it through the device manager and also through double clicking the setup files and running it again (which brings up an option to repair of uninstall, both of which I've tried).

Unfortunately, removing it from the Add/Remove list doesn't change any of the results. 

Just a quick update: I have tried a clean install of windows at this point, and unfortunately, that made no difference either.

Officially you'll need to check with your motherboard manufacturer's support team.  Code 10 is often competing hardware or some other non compliant driver. Had you updated any other drivers recently to updating the ME driver?

That's the tricky part. I just built this PC so I had to update all drivers. The first thing I did after installing Windows though was to use my motherboard CD to install all drivers from it. These drivers should not have any issues with one another since they are from the manufacturer. But even with just those drivers installed the code 10 happens. I've been in contact with the manufacturer and their suggestion was to reinstall windows--which, again, I did. So now I am just waiting to hear back from them on the matter again.

I'm wondering if it is a bad driver on their end. I've found a lot of people with similar issues, but most just end up turning the device off and ignoring it while avoiding using Sleep. 

Well if it were my system, I'd go in and disable drivers to find out what makes the sleep issue go away (also checking Event Log, any dumps/minidumps). That's probably the source of both. Did you use the chipset inf driver from the Intel download site?

I did try disabling some of them to find out what was causing it. And I checked the Event Log too but could not quite discern the root of the issue. I'll have to look again later. I did notice one other device that was acting strangely during all this though. The Ethernet device: it would have trouble starting anytime I boot the PC up. It works just fine if the PC is simply restarted. But if I shut it down completely (or put it into hibernate which I don't use anyway), then start it up, the device won't come on by itself. It is listed as disabled in the device manager and I have to go in and enable it--and then it works fine though.

Update: I have done more digging and checked the Event Log again and found that, according to my PC, the error comes from the fact that the driver fails the handshake with the firmware. This makes it sound more like a compatibility issue than anything else. I am now wondering if downgrading my bios to an earlier version could help--is that even possible if my motherboard came with the latest version already installed?

My board's manufacturer's only suggestion at this point is to file an RMA, but I am reluctant to do that if this is not an actual hardware issue. Chances are they would just send me another with the same BIOS version, solving nothing.  

Only your motherboard manufacturer can really speak to that. But my personal opinion is if they've already offered to warranty the board - you'll be covered if it bricks while you try a BIOS downgrade.   Check what BIOS it came with originally/


I have not read through the whole thread, but your system does not have vPro technology:

I don't know what version of the ME it would need since it doesn't support vPro - probably some smaller build.  YOUR board manufacturer should be able to tell you which one you need.  

But this doesn't sound like an ME issue since your system is crashing when you put it to sleep.  You could try the driver update utility:

Maybe the tool will work to find out which driver you need.

Also if you go out to the link above and click on software downloads, you will see a lot of graphics drivers - maybe your graphics driver is acting up?





 After installing Intel Management Engine i am getting restarts and crashing. I had windows 7 installed and had this issue so i did a fresh install of windows 10 x64. I updated the latest IME driver and had the same issues. My motherboard is a z97 gaming 9 ack and with the latest bios updated. I have fully tested my system and only experience crashing on this version of IME driver. If i go back to a older driver i don't have a problem and no crashing. I am under the impression there is a problem with this driver and it does need to be addressed as it does cause problems with booting up and data corruption due to the crashing. Trying to find why the fault is happening is hard and if intel want anymore info then let me know and i can give you a list of all my devices as it took me a while to figure out it was this driver causing my problems. Cheers


I am having problem with the Intel Management Engine Interface, I cannot roll back my driver or update my driver. Since,I have upgraded to windows 10 my laptop is having problems with sleep and shutdown and hence i tried to roll back the engine interface. 



Downloadimage/jpeg Capture.JPG30.46 KB


What platform are you running (like OEM system?)  If you updated the OS, you will need to go to your OEM's Support site and get the correct MEI drivers and LMS/IMSS software for your system.  If you are still having issues, you may need to reflash your firmware - which your OEM support site should have as well.



I've looked up my oem37.inf, inside there it was something like this: 

; ************************************************************
; ************************************************************
; **  Filename: SkylakeSystemGMM.inf                        **
; **  Abstract: Assigns the null driver to devices          **
; **            for yellow-bang removal and                 **
; **            brands Intel(R) devices                     ** 
; ************************************************************
; ************************************************************

Hope this helps! 


p.s. Try use Everything, it has superpower on searching files! 

Leave a Comment

Please sign in to add a comment. Not a member? Join today