AMT/VNC headless on Linux results in black screen or no mouse/keyboard

AMT/VNC headless on Linux results in black screen or no mouse/keyboard

Hello,

I installed Ubuntu Server 64bit 12.10 on a Dell Poweredge T20 and wanted to run it headless, but I ran into the following problem, that when no monitor was attached, or if you send the system into standby and wake it up again, the screen is black if connected via VNC. I found this old thread: https://software.intel.com/en-us/forums/topic/279956 where it was suggested to add "nomodeset" to GRUB config, which I did, and it seemed to work at first. I now got a VNC signal too after standby wakeup, but now the mouse/keyboard doesnt work anymore. The video picture still works, because I can see the time changing on my Ubuntu desktop, but the VNC doesnt accept any mouse nor keyboard input anymore. When I reboot, the issue is gone, but the moment I do the same, send the system into standby via pm-suspend, wake it up again via WOL, it's broken. I also noticed, that the nomodeset option results in the video driver not working anymore correctly (with hardware acceleration), because I see large CPU consumption of "Compiz" and X server.

11 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Could  you clarify if you're trying to get into the BIOS or to the running OS? (and have you tried both to see if one works?)

It's Ubuntu 14.10 installation, kernel 3.16.0-33, so I was talking about after entering OS. VNC becomes black without kernel option nomodeset, like stated in that old (3 years old) post https://software.intel.com/en-us/forums/topic/279956 and if powered on from suspend, mouse and keyboard input arent working anymore. And with nomodeset option, hardware acceleration seems to be deactivated and everything becomes slow over VNC, so thats not really an option.

This sounds more like a Ubuntu / RealVNC issue - have you setup like described in https://www.digitalocean.com/community/tutorials/how-to-setup-vnc-for-ubuntu-12

Aehem... of course software based VNC works. But my thread is about the hardware implemented VNC server in the vPro enviroment... Yes I have a backup vnc running, tightvncserver, because otherwise I wouldnt be able to connect anymore, because the vPro VNC stops working if 

1.) kernel isnt booted with nomodeset => black screen after a while of idling

or

2.) after suspend resume, mouse and keyboard input arent working anymore on the vPro VNC

I thought it was a USB problem maybe so I switched to PS/2 mouse and keyboard, even tried no real mouse and keyboard connected to the mechine at all. Doesnt matter, the moment the PC returns from standby, mouse nor keyboard arent working anymore over the vPro VNC, whatever client you use, RealVNC, TightVNC, or whatsoever.

What are your ME power state settings?

I didnt change anything in the MEBx except setting password and enabling AMT, web interface says it's set to: "Desktop: ON in S0, ME Wake in S3, S4-5". Web interface always woks, waking up via WOL works too, but remote mouse and keyboard arent working anymore after coming back from standby.

I have tested it with Windows 7 now too, have both installed on that PC. It's the same. When Windows comes back from standby, remote mouse and keyboard arent working anymore.

but if you plug in a monitor (to the Dell), then all works fine?  What video card/driver do you have?

You mean for the black screen issue? Yes, when a monitor is connected and it's on, the black screen on the VNC goes away the moment the monitor turns on and remote VNC gets a picture. This has nothing to do with the standby mouse/keyboard issue though. GPU is Xeon E3-1225 v3, so it's an Intel HD Graphics P4600 (IGP).

Did you try Windows 7 on the same system? Have you tried other systems with the same version of ME FW? Is it possibly a wake on (perhaps PS/2) setting on the system?

Leave a Comment

Please sign in to add a comment. Not a member? Join today