Resetting AMT through a Motherboard BIOS re-flash

Resetting AMT through a Motherboard BIOS re-flash

I have an unsolvable problem: I am unable to login into AMT through WEB interface and OpenMDTK tools (commander and director). Instead I am able to log into MEBx.

All this as a result of some experiments made in the past through the configuration tool for linux (ACUConfig) with an unsupported OS (Ubuntu 12.04) and an unprovisioning made by the OpenMDTK tools and after changing some parameters of AMT in the BIOS and in MEBx interface.
All this happened a long time ago and I can not remember exactly what I did.
Following this, I fear that my AMT is rather messy so I think to re-flash the BIOS of the motherboard to "reset" AMT completely then clear CMOS.
However I don't Know if this will HELP therefore I'm here to ask it to You.

What I recently did:

- Disabled AMT in BIOS (then re-enabled) and resetted CMOS (Otherwise I was unable to enter MEBx menu with CTRL-P)

- To be sure unprovisioning secceded, I've also unprovisioned AMT through "AMT Configuration ---> Un-Configure ME" item in BIOS menu (this option allows to Un-Configure ME without a password).

- Reconfigured AMT through MEBx interface after having entered a new password (tried: P-ssw0rd, P@ssw0rd, and some other pwds)

- Tried to login in AMT through Web Interface (http://ip_address:16992) with user "admin" and password entered during MEBx configuration with no success. DHCP is enabled in AMT configuration therefore ip_address is shared with host ip_address.

- Tried to login also through OpenMDTK tools (commander and director) with same credentials but no success.

I've also tried setting a static address in MEBx interface (and I've also setted my host address as static as explained in AMT reference guide) however I was unable to access "logon" web page with this new address while I was still able to access "logon" web page with my host ip address.
To be precise, my AMT static address as setted in MEBx was "192.168.1.5 - 255.255.255.0" and my host address was "192.168.1.2 - 255.255.255.0". I was able to enter "logon" web page with 192.168.1.2 address but not with 192.168.1.5 address. I think this is abnormal behavior.

Therefore I think to reset AMT completely but I don't know how to do. I hope this is possible reflashing BIOS but I'm not sure this will reset/clear everything.

My AMT version is 8.0.10. My motherboard is SUPERMICRO X9SAE and no AMT firmware updates have been released by Supermicro neither BIOS updates in last 18 months.

I know AMT minor releases upgrades are possible only through OEM. Is there any unofficial way to update AMT bypassing OEM (Supermicro)?

Excuse me for my poor English (I hope you understood what I tried to say). Thanks in advance.

13 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Are you using wired or wireless connection?  When you say you could log in with the .2 address, meaning you could see the AMT screen from .2?

I'm using wired connection and I'm connecting from host pc (same pc where is amt).

Yes, when I say I can log in with .2 address this means I can see AMT logon page (web interface) from .2 and I can access this page typing (http://192.168.1.2:16992) in browser address bar.

Just re-flashed BIOS and ME firmware.

Now Intel ME version is v8.0.13.1502 and MEBx version is v8.0.0.0063 (as you can se on MEBx interface presentation page)

This is odd because ME firmware version seems newer instead MEBx version seems older (previous MEBX version was v8.0.0.0064).

However problem persists: still unable to login into web interface.

Sorry I'm confused. Are .2 and .5 the same computer, just the OS vs the AMT interface? Or 2 separate machines? If they are the same computer, what is it that you expect to see on web login that you are not seeing?

Exact! .2 and .5 are the same computer.

.5 is AMT static ip address (as setted in MEBx UI --> Network Setup) instead .2 is host pc static ip address as setted in Operating System.

Typing .5 ip address in my browser address bar, I was expecting to see AMT logon page appearing instead I can't see anything. Abnormally, I think, I can see AMT logon page appearing, only if I type .2 address in browser address bar (namely, typing the same ip address than host (.2) but not the one I setted in AMT MEBx UI (.5)). I think this would be normal if I had choosen DHCP in "MEBx UI Network settings" but I think it's not normal since I've choosen and inserted a different static address from the host computer one.

However this is not important for me now!!!! The important thing is to know how completely reset my AMT/MEBx configuration data (I didn't understand where are they stored ...I've read somewhere in BIOS flash chip, is this true?).

In past, I've experienced that unconfiguring ME from BIOS (in my BIOS UI there is a item to do that, named "ME Un-configure") also WEB UI password was deleted. Now I'm not able to do this operation in any way

Therefore I would like to know how to reset/delete all users/passwords (a different method than "ME Un-configure" item in BIOS menu ...that doesn't work). I hope there is a way to do that.

Thank you but I already read this guide and in my case it is not useful.
Unfortunately my problem was more complicated however I managed to solve it anyway by myself.
I do not know exactly what was helpful to solve my problem however here is what I did:

- Re-flashed BIOS and ME firmware (if ME firmware and BIOS are separate files I think it should be not necessary to re-flash BIOS too)
- Removed MB battery
- Reinserted battery then Resetted CMOS
- Entered BIOS interface and loaded defaults settings
- In my motherboard (Supermicro X9SAE) there is a jumper (JPME1) named "ME Recovery" to reset AMT ME data (this jumper is probably also on other AMT/IPMI capable motherboards). The jumper is supposed to cause ME to enter recovery boot loader code and reset ME firmware configuration to factory defaults. Here following how to use it (instructions accidentally found with google in a Server Platform Services "SPS" ME firmware release notes file):

  1. User shuts down the system and disconnects AC power
  2. Asserts ME recovery jumper
  3. Connects AC power and starts system with power button
  4. At this moment ME should start recovery boot loader and reset configuration to defaults
  5. User shuts down the system and disconnects AC power
  6. De-asserts ME recovery jumper
  7. Connects AC power and starts system with power button

    At this moment ME operational code should start with factory default configuration. If ME recovery jumper does not reset ME configuration to factory defaults, in step (3) do not allow booting OS, but disconnect AC power in the first few seconds, during BIOS POST. Then connect AC power again and go on with steps (4) and forwarded.

- Reconfigured AMT through MEBx user interface.
- Entered AMT WEB interface (with user: "admin" and password set during previous configuration).
- At this point I was able to access again WEB UI without authentication problems.

As a reminder:

In normal conditions AMT could be UNPROVISIONED in this way:

- From BIOS Interface enabling "ME Un-configure" in AMT settings. This reset all settings and also reset all users/passwords (to "admin - admin" and it is useful if MEBx password is lost

- From MEBx interface chosing FULL UNPROVISION or PARTIAL unprovision. MEBx password and some others settings are kept.

Hello

we made a very old computer to a server via SCS Amt configuration.This server is no longer used.We have established a new SCS server.Unable to take unprovision action.Because we do not know the AMT password from the old server.

How can we learn the old password or reset  ?

We are waiting for help

Regards.

Greetings

There is no way of "learning" the password. You will need to perform reset of the Intel AMT Firmware by removing the CMOS battery of the AMT clients being effected.

 

Joe

 

Do not have this process much simpler management will be done in a computer?

If you have an article you know, I'm glad you shared.

Greetings

When it comes to the AMT Firmware password if that password is lost or forgotten your only choice is to remove the CMOS battery from the board. The exact procedure to do this is different for each model, my recommendation is to locate a tear down guide.

Additional Information

When SCS is used for configuration of intel AMT devices. this automatically puts them in "Admin Control Mode", during this process the MEBx (AMT Firmware) has a password assigned that is = to the password in the configuration profile. As you have lost this password, the only option I know of is pulling the CMOS battery

 

 

 

In BIOS interface you should search for AMT Settings and here for an option like "ME Un-configure" or "AMT Un-configure". This should reset all settings and also reset all users/passwords (to "admin - admin" and it is useful if MEBx password is lost).

If you are unable to reset password in this way you should try resetting cmos, removing battery or refleshing bios with the option to reflash amt too (see mb manual).

Leave a Comment

Please sign in to add a comment. Not a member? Join today